summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pixie/pixie-2.2.6-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pixie/pixie-2.2.6-r1.ebuild')
-rw-r--r--media-gfx/pixie/pixie-2.2.6-r1.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/media-gfx/pixie/pixie-2.2.6-r1.ebuild b/media-gfx/pixie/pixie-2.2.6-r1.ebuild
new file mode 100644
index 000000000000..50baf2d88cc7
--- /dev/null
+++ b/media-gfx/pixie/pixie-2.2.6-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+WANT_AUTOMAKE="1.10"
+
+inherit eutils multilib autotools
+
+MY_PN="Pixie"
+S="${WORKDIR}/${MY_PN}"
+
+DESCRIPTION="RenderMan like photorealistic renderer"
+HOMEPAGE="http://pixie.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-src-${PV}.tgz"
+
+LICENSE="GPL-2"
+IUSE="X static-libs"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+RDEPEND="virtual/jpeg
+ media-libs/tiff
+ media-libs/libpng
+ x11-libs/fltk:1[opengl]
+ media-libs/openexr
+ virtual/opengl
+ sys-libs/zlib
+ X? (
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-zlib-1.2.5.2.patch
+ # FIX: missing @includedir@
+ # https://sf.net/tracker/?func=detail&aid=2923415&group_id=59462&atid=491094
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+
+ # FIX: removing pre-compiled shaders
+ # shaders must be removed before of their compilation or make
+ # parallelism can break the regeneration process, with resulting
+ # missing shaders.
+ rm "${S}"/shaders/*.sdr
+}
+
+src_configure() {
+ # NOTE: the option program-transform-name is used to avoid binary name
+ # conflict with package: mail-client/nmh (see #295996)
+ econf \
+ $(use_with X x) \
+ $(use_enable static-libs static) \
+ --includedir=/usr/include/pixie \
+ --libdir=/usr/$(get_libdir)/pixie \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ --with-shaderdir=/usr/share/Pixie/shaders \
+ --with-ribdir=/usr/share/Pixie/ribs \
+ --with-texturedir=/usr/share/Pixie/textures \
+ --with-displaysdir=/usr/$(get_libdir)/pixie/displays \
+ --with-modulesdir=/usr/$(get_libdir)/pixie/modules \
+ --enable-openexr-threads \
+ --disable-static-fltk \
+ --mandir=/usr/share/man \
+ --bindir=/usr/bin \
+ --program-transform-name="s/show/pixie-show/"
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ # regenerating Pixie shaders - see upstream bug report:
+ # https://sf.net/tracker/?func=detail&aid=2923407&group_id=59462&atid=491094
+ einfo "Re-building Pixie Shaders for v${PV} format"
+ emake -f "${FILESDIR}/Makefile.shaders" -C "${S}/shaders" || die "shaders rebuild failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed."
+
+ insinto /usr/share/Pixie/textures
+ doins "${S}"/textures/*
+
+ # remove useless .la files
+ find "${D}" -name '*.la' -delete || die "removal of libtool archive files failed"
+
+ dodoc README AUTHORS ChangeLog || die
+}