summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-08-06 11:04:19 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-08-06 11:04:44 +0100
commit8b8d4cd4df4d0fb2c21f4e0f06cf51c489e1f861 (patch)
tree9d4d4eee3a01b00a378e3227b15ca472991986c6 /media-gfx/plantuml/plantuml-8046.ebuild
parentapp-vim/notes: Clean up old. (diff)
downloadgentoo-8b8d4cd4df4d0fb2c21f4e0f06cf51c489e1f861.tar.gz
gentoo-8b8d4cd4df4d0fb2c21f4e0f06cf51c489e1f861.tar.bz2
gentoo-8b8d4cd4df4d0fb2c21f4e0f06cf51c489e1f861.zip
media-gfx/plantuml: Bump to 8046, fix ant-core dep, closes #527528
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-gfx/plantuml/plantuml-8046.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-8046.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/plantuml/plantuml-8046.ebuild b/media-gfx/plantuml/plantuml-8046.ebuild
new file mode 100644
index 000000000000..64b36a6d968a
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-8046.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="http://plantuml.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+
+RDEPEND=">=virtual/jre-1.7
+ dev-java/ant-core:0
+ >=media-gfx/graphviz-2.26.3"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+}