summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-14 02:08:08 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-14 02:08:39 +0100
commit0605f361b5e371c6b82dab684128be5642ccc204 (patch)
tree6ae5e7d304173591f1ae263514809c44eea8155a /media-gfx/pngquant/pngquant-2.12.2.ebuild
parentmedia-gfx/libimagequant: bump to v2.12.2 (diff)
downloadgentoo-0605f361b5e371c6b82dab684128be5642ccc204.tar.gz
gentoo-0605f361b5e371c6b82dab684128be5642ccc204.tar.bz2
gentoo-0605f361b5e371c6b82dab684128be5642ccc204.zip
media-gfx/pngquant: bump to v2.12.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-gfx/pngquant/pngquant-2.12.2.ebuild')
-rw-r--r--media-gfx/pngquant/pngquant-2.12.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-gfx/pngquant/pngquant-2.12.2.ebuild b/media-gfx/pngquant/pngquant-2.12.2.ebuild
new file mode 100644
index 000000000000..5bc16502eb65
--- /dev/null
+++ b/media-gfx/pngquant/pngquant-2.12.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="command-line utility and library for lossy compression of PNG images"
+HOMEPAGE="https://pngquant.org/"
+SRC_URI="https://pngquant.org/${P}-src.tar.gz"
+
+LICENSE="GPL-3 HPND rwpng"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug lcms openmp cpu_flags_x86_sse2"
+
+RDEPEND="media-libs/libpng:0=
+ media-gfx/libimagequant:=
+ sys-libs/zlib:=
+ lcms? ( media-libs/lcms:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.12.2-respect-CFLAGS.patch )
+
+src_prepare() {
+ default
+
+ # avoid silent fallback to bundled lib
+ rm -rv lib || die
+}
+
+src_configure() {
+ tc-export AR CC
+ # Hand rolled configure script, so not all flags are supported.
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-libimagequant \
+ $(use debug && echo --enable-debug) \
+ $(use_enable cpu_flags_x86_sse2 sse) \
+ $(use openmp && tc-has-openmp && echo --with-openmp) \
+ $(use_with lcms lcms2) \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc CHANGELOG README.md
+}