summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/povray/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/povray/files')
-rw-r--r--media-gfx/povray/files/povray-3.7.0.0-automagic.patch27
-rw-r--r--media-gfx/povray/files/povray-3.7.0.0-boost-1.50.patch72
-rw-r--r--media-gfx/povray/files/povray-3.7.0.0-user-conf.patch27
-rw-r--r--media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch21
4 files changed, 147 insertions, 0 deletions
diff --git a/media-gfx/povray/files/povray-3.7.0.0-automagic.patch b/media-gfx/povray/files/povray-3.7.0.0-automagic.patch
new file mode 100644
index 000000000000..a7c776f13fb6
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0.0-automagic.patch
@@ -0,0 +1,27 @@
+ unix/configure.ac | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f62f5d4..d9a3750 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -335,10 +335,15 @@ fi
+ AC_DEFINE([USE_OFFICIAL_BOOST], [], [Use the official Boost libraries.])
+
+ # Intel Math Kernel library
+-pov_save_ldflags="$LDFLAGS"
+-test x"$with_libmkl" != x"" && LDFLAGS="-L$with_libmkl $LDFLAGS"
+-AC_CHECK_LIB([mkl], [sin])
+-test x"ac_cv_lib_mkl_sin" = x"no" && LDFLAGS="$pov_save_ldflags"
++AS_IF([test x"$with_libmkl" != x"no"], [
++ pov_save_ldflags="$LDFLAGS"
++ AS_IF([test x"$with_libmkl" != x"yes"], [
++ LDFLAGS="-L$with_libmkl $LDFLAGS"
++ ])
++ AC_CHECK_LIB([mkl], [sin], [], [
++ AC_MSG_ERROR([Cannot find working mkl library])
++ ])
++])
+
+ # libm
+ AC_CHECK_LIB([m], [sin])
diff --git a/media-gfx/povray/files/povray-3.7.0.0-boost-1.50.patch b/media-gfx/povray/files/povray-3.7.0.0-boost-1.50.patch
new file mode 100644
index 000000000000..f8e807ad647d
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0.0-boost-1.50.patch
@@ -0,0 +1,72 @@
+ configure.ac | 26 ++++++--------------------
+ vfe/unix/platformbase.cpp | 2 +-
+ 2 files changed, 7 insertions(+), 21 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 51596f8..900c150 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -57,8 +57,6 @@ AC_CONFIG_SRCDIR([unix/disp_text.cpp])
+ m4_include([unix/config/acx_pthread.m4])
+ m4_include([unix/config/ax_arg_enable.m4])
+ m4_include([unix/config/ax_arg_with.m4])
+-m4_include([unix/config/ax_boost_base.m4])
+-m4_include([unix/config/ax_boost_thread.m4])
+ m4_include([unix/config/ax_test_compiler_flags.m4])
+ m4_include([unix/config/ax_check_lib.m4])
+ m4_include([unix/config/ax_check_libjpeg.m4])
+@@ -168,6 +166,7 @@ AC_CANONICAL_HOST
+
+ AM_INIT_AUTOMAKE([1.9 dist-bzip2])
+ AM_MAINTAINER_MODE
++LT_INIT
+
+ AX_FIX_INCORRECT_PATH(C_INCLUDE_PATH, ".", [pov_warn_path="$pov_warn_path C_INCLUDE_PATH"])
+ AX_FIX_INCORRECT_PATH(CPLUS_INCLUDE_PATH, ".", [pov_warn_path="$pov_warn_path CPLUS_INCLUDE_PATH"])
+@@ -298,28 +297,15 @@ LIBS="$LIBS $PTHREAD_CFLAGS $PTHREAD_LIBS" # append
+
+ # Boost; required library
+ # the following macro stops with error when boost is not found
+-AX_BOOST_BASE([$required_libboost_version])
+-AX_BOOST_THREAD
+-if test x"$ax_cv_boost_thread" != x"yes"; then
++BOOST_REQUIRE([$required_libboost_version])
++BOOST_THREADS
++if test x"$boost_cv_lib_thread" != x"yes"; then
+ AC_MSG_ERROR([cannot find a suitable boost thread library])
+ else
+ CPPFLAGS="$CPPFLAGS $BOOST_CPPFLAGS" # append
+- LDFLAGS="$LDFLAGS $BOOST_LDFLAGS" # append
+- LIBS="$BOOST_THREAD_LIB $LIBS"
++ LDFLAGS="$LDFLAGS -L$BOOST_LDPATH" # append
++ LIBS="$BOOST_THREAD_LIBS $LIBS"
+ fi
+-AC_MSG_CHECKING([whether the boost thread library is usable])
+-AC_RUN_IFELSE(
+- [AC_LANG_PROGRAM([[
+-#include <boost/thread/thread.hpp>
+- ]],
+- [[boost::defer_lock_t(); return 0;]])],
+- [AC_MSG_RESULT([yes])],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_FAILURE([cannot link with the boost thread library])
+- ],
+- [AC_MSG_RESULT([cross-compiling])] # FIXME
+-)
+ AC_DEFINE([USE_OFFICIAL_BOOST], [], [Use the official Boost libraries.])
+
+ # Intel Math Kernel library
+diff --git a/vfe/unix/platformbase.cpp b/vfe/unix/platformbase.cpp
+index 8669d19..83c0191 100644
+--- a/vfe/unix/platformbase.cpp
++++ b/vfe/unix/platformbase.cpp
+@@ -68,7 +68,7 @@ namespace pov_base
+ #else
+ // taken from source/base/timer.cpp
+ boost::xtime t;
+- boost::xtime_get(&t, boost::TIME_UTC);
++ boost::xtime_get(&t, POV_TIME_UTC);
+ POV_ULONG ns = (POV_ULONG)(t.sec) * (POV_ULONG)(1000000000) + (POV_ULONG)(t.nsec) + (POV_ULONG)(msec) * (POV_ULONG)(1000000);
+ t.sec = (boost::xtime::xtime_sec_t)(ns / (POV_ULONG)(1000000000));
+ t.nsec = (boost::xtime::xtime_nsec_t)(ns % (POV_ULONG)(1000000000));
diff --git a/media-gfx/povray/files/povray-3.7.0.0-user-conf.patch b/media-gfx/povray/files/povray-3.7.0.0-user-conf.patch
new file mode 100644
index 000000000000..b3c279fcdeff
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0.0-user-conf.patch
@@ -0,0 +1,27 @@
+ Makefile.am | 13 -------------
+ 1 files changed, 0 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 76b394c..9822c52 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -107,19 +107,6 @@ install-data-local:
+ for f in $$filelist ; do \
+ $(INSTALL_DATA) $(top_srcdir)/doc/$$f $(DESTDIR)$(povdocdir)/$$f && echo "$(DESTDIR)$(povdocdir)/$$f" >> $(povinstall); \
+ done
+- @echo "Creating user directories..."; \
+- for p in $(povuser) $(povconfuser) ; do \
+- $(MKDIR_P) $$p && chown $(povowner) $$p && chgrp $(povgroup) $$p && printf "%s\n" "$$p" "`cat $(povinstall)`" > $(povinstall); \
+- done
+- @echo "Copying user configuration and INI files..."; \
+- for f in povray.conf povray.ini ; do \
+- if test -f $(povconfuser)/$$f; then \
+- echo "Creating backup of $(povconfuser)/$$f"; \
+- mv -f $(povconfuser)/$$f $(povconfuser)/$$f.bak; \
+- fi; \
+- done; \
+- $(INSTALL_DATA) $(top_srcdir)/povray.conf $(povconfuser)/povray.conf && chown $(povowner) $(povconfuser)/povray.conf && chgrp $(povgroup) $(povconfuser)/povray.conf && echo "$(povconfuser)/povray.conf" >> $(povinstall); \
+- $(INSTALL_DATA) $(top_builddir)/povray.ini $(povconfuser)/povray.ini && chown $(povowner) $(povconfuser)/povray.ini && chgrp $(povgroup) $(povconfuser)/povray.ini && echo "$(povconfuser)/povray.ini" >> $(povinstall)
+
+ # Remove data, config, and empty folders for 'make uninstall'.
+ # Use 'hook' instead of 'local' so as to properly remove *empty* folders (e.g. scripts).
diff --git a/media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch b/media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch
new file mode 100644
index 000000000000..16e09c749b2e
--- /dev/null
+++ b/media-gfx/povray/files/povray-3.7.0_rc6-darwin-defaults.patch
@@ -0,0 +1,21 @@
+# Darwin does not support thread-local storage (__thread)
+# http://lists.apple.com/archives/xcode-users/2006/Jun/msg00551.html
+# so use default from boost thread
+
+# use lseek for lseek64
+# sys/types.h is needed because of uint
+
+--- povray-3.7.0.RC6/vfe/unix/syspovconfig.h.orig 2013-03-01 11:09:42.000000000 -0700
++++ povray-3.7.0.RC6/vfe/unix/syspovconfig.h 2013-03-01 11:07:14.000000000 -0700
+@@ -171,9 +171,7 @@
+ #define METADATA_PLATFORM_STRING BUILD_ARCH
+ #define METADATA_COMPILER_STRING COMPILER_VERSION
+
+-#define DECLARE_THREAD_LOCAL_PTR(ptrType, ptrName) __thread ptrType *ptrName
+-#define IMPLEMENT_THREAD_LOCAL_PTR(ptrType, ptrName, ignore) __thread ptrType *ptrName
+-#define GET_THREAD_LOCAL_PTR(ptrName) (ptrName)
+-#define SET_THREAD_LOCAL_PTR(ptrName, ptrValue) (ptrName = ptrValue)
++#define lseek64 lseek
++#include <sys/types.h>
+
+ #endif