summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-12 20:49:36 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-12 21:32:24 -0600
commitaab9fbb4a00eb0e7ee710ed1b0d1ebe484f3cfc3 (patch)
treefaee5f4e2607090ee36f3f10b41bbc3fb60acc2c /media-gfx/pqiv
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-aab9fbb4a00eb0e7ee710ed1b0d1ebe484f3cfc3.tar.gz
gentoo-aab9fbb4a00eb0e7ee710ed1b0d1ebe484f3cfc3.tar.bz2
gentoo-aab9fbb4a00eb0e7ee710ed1b0d1ebe484f3cfc3.zip
media-gfx/pqiv: version bump to 2.11
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-gfx/pqiv')
-rw-r--r--media-gfx/pqiv/Manifest1
-rw-r--r--media-gfx/pqiv/pqiv-2.11.ebuild79
-rw-r--r--media-gfx/pqiv/pqiv-9999.ebuild2
3 files changed, 81 insertions, 1 deletions
diff --git a/media-gfx/pqiv/Manifest b/media-gfx/pqiv/Manifest
index f1b8f3b919f5..ba294e48b771 100644
--- a/media-gfx/pqiv/Manifest
+++ b/media-gfx/pqiv/Manifest
@@ -1,2 +1,3 @@
DIST pqiv-2.10.2.tar.gz 138506 BLAKE2B 255104acec9d42eac52d8aaf05207fc8071ecbef14a04c5952e70347d0cd83b54b00725b9bb949184bcd9437982701814b6a09c4c2397336f26ce9f50896d2e6 SHA512 99cb3a187fa2cc0df7b7f768b2f801fbec78aa8d76aacd12085f3b8ccbfaf931a2379e7b05a92f83dacf511489518a75f9e5bf528e4152158d8bb75cffb0d6f7
DIST pqiv-2.10.4.tar.gz 138644 BLAKE2B 7dc358379d463e6b421c082942a2171b749ea41b4e655c64425d6cfdf8f251ce89d431b45a28d8b30eb5c022814bec7e365c3b3272ebf0cc7e994b803ddfd4ec SHA512 52534ed4728466b7c710db65115d7e79ad97546750946fa5c3a26b65055387b15c6239fdf1bb8c8345fe7ed2dfc7ed5586ffa2a864de44fd8213cff59f76048a
+DIST pqiv-2.11.tar.gz 139825 BLAKE2B 981d472ccd3284b2e9ad3da8e84233c95555a927af797f8421ac820225d3d39cab2275f01269a986bab54994e0fce2095b7c33b1201e7a6117e1c8399617341b SHA512 6017a9d7ed332915a9f6fa788bb02c3b9d4d83c2ae2f9a8ab7d7738caa14ba3e9d253906f2e73fdfd368bb5e7bc51380ee9906fd9921e5f7f113811fd3da66f7
diff --git a/media-gfx/pqiv/pqiv-2.11.ebuild b/media-gfx/pqiv/pqiv-2.11.ebuild
new file mode 100644
index 000000000000..499cd72f5f50
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.11.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info toolchain-funcs xdg-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/phillipberndt/pqiv.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="powerful GTK 3 based command-line image viewer with a minimal UI"
+HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="archive ffmpeg imagemagick kernel_linux libav pdf postscript webp"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/cairo-1.6
+ x11-libs/gtk+:3
+ archive? ( app-arch/libarchive:0= )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:0= )
+ )
+ imagemagick? ( media-gfx/imagemagick:0= )
+ pdf? ( app-text/poppler:0= )
+ postscript? ( app-text/libspectre:0= )
+ webp? ( media-libs/libwebp:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local backends="gdkpixbuf"
+ use archive && backends+=",archive,archive_cbx"
+ use ffmpeg || use libav && backends+=",libav"
+ use imagemagick && backends+=",wand"
+ use pdf && backends+=",poppler"
+ use postscript && backends+=",spectre"
+ use webp && backends+=",webp"
+
+ doecho ./configure \
+ --backends-build=shared \
+ --backends=${backends} \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --destdir="${ED}"
+}
+
+src_compile() {
+ tc-export CC
+ emake VERBOSE=1 CFLAGS="${CFLAGS}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/media-gfx/pqiv/pqiv-9999.ebuild b/media-gfx/pqiv/pqiv-9999.ebuild
index 92c15ed6806f..499cd72f5f50 100644
--- a/media-gfx/pqiv/pqiv-9999.ebuild
+++ b/media-gfx/pqiv/pqiv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6