summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-15 12:18:11 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-15 12:18:30 +0200
commitcfcb21113f746f5f8cb8ea27d2c6f90819e790aa (patch)
tree5221aed64aa6319641669b643b9f75a8a5710c09 /media-gfx/printrun/printrun-20150310-r1.ebuild
parentapp-mobilephone/wammu: Version bump (diff)
downloadgentoo-cfcb21113f746f5f8cb8ea27d2c6f90819e790aa.tar.gz
gentoo-cfcb21113f746f5f8cb8ea27d2c6f90819e790aa.tar.bz2
gentoo-cfcb21113f746f5f8cb8ea27d2c6f90819e790aa.zip
media-gfx/printrun: Apply Fedora fixes, also improving support with gtk3 and wxpython3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-gfx/printrun/printrun-20150310-r1.ebuild')
-rw-r--r--media-gfx/printrun/printrun-20150310-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/printrun/printrun-20150310-r1.ebuild b/media-gfx/printrun/printrun-20150310-r1.ebuild
new file mode 100644
index 000000000000..3185dcf2a6d7
--- /dev/null
+++ b/media-gfx/printrun/printrun-20150310-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="GUI interface for 3D printing on RepRap and other printers"
+HOMEPAGE="https://github.com/kliment/Printrun"
+SRC_URI="https://github.com/kliment/Printrun/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyserial
+ dev-python/wxpython:*
+ dev-python/pyglet
+ dev-python/dbus-python
+ media-gfx/cairosvg"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Printrun-${P}"
+
+PATCHES=(
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1231518
+ "${FILESDIR}"/${PN}-gtk3.patch
+
+ # https://github.com/kliment/Printrun/pull/790
+ "${FILESDIR}"/${PN}-x11.patch
+)