summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pydot/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pydot/files')
-rw-r--r--media-gfx/pydot/files/pydot-1.0.23-setup.patch21
-rw-r--r--media-gfx/pydot/files/pydot-1.0.28-pyparsing2fix.patch14
2 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/pydot/files/pydot-1.0.23-setup.patch b/media-gfx/pydot/files/pydot-1.0.23-setup.patch
new file mode 100644
index 000000000000..c87cc32b30d1
--- /dev/null
+++ b/media-gfx/pydot/files/pydot-1.0.23-setup.patch
@@ -0,0 +1,21 @@
+--- setup.py
++++ setup.py
+@@ -1,9 +1,9 @@
+ #!/usr/bin/env python
+
+ try:
+- from distutils.core import setup
+-except ImportError, excp:
+ from setuptools import setup
++except ImportError, excp:
++ from distutils.core import setup
+
+ import pydot
+ import os
+@@ -31,5 +31,4 @@
+ 'Topic :: Software Development :: Libraries :: Python Modules'],
+ long_description = "\n".join(pydot.__doc__.split('\n')),
+ py_modules = ['pydot', 'dot_parser'],
+- install_requires = ['pyparsing', 'setuptools'],
+- data_files = [('.', ['LICENSE', 'README'])] )
++ install_requires = ['pyparsing', 'setuptools'] )
diff --git a/media-gfx/pydot/files/pydot-1.0.28-pyparsing2fix.patch b/media-gfx/pydot/files/pydot-1.0.28-pyparsing2fix.patch
new file mode 100644
index 000000000000..12a01091223c
--- /dev/null
+++ b/media-gfx/pydot/files/pydot-1.0.28-pyparsing2fix.patch
@@ -0,0 +1,14 @@
+diff -up pydot-1.0.28/dot_parser.py.pyparsing2fix pydot-1.0.28/dot_parser.py
+--- pydot-1.0.28/dot_parser.py.pyparsing2fix 2013-12-09 08:59:24.660145534 -0500
++++ pydot-1.0.28/dot_parser.py 2013-12-09 09:00:10.021222397 -0500
+@@ -25,8 +25,9 @@ from pyparsing import __version__ as pyp
+ from pyparsing import ( nestedExpr, Literal, CaselessLiteral, Word, Upcase, OneOrMore, ZeroOrMore,
+ Forward, NotAny, delimitedList, oneOf, Group, Optional, Combine, alphas, nums,
+ restOfLine, cStyleComment, nums, alphanums, printables, empty, quotedString,
+- ParseException, ParseResults, CharsNotIn, _noncomma, dblQuotedString, QuotedString, ParserElement )
++ ParseException, ParseResults, CharsNotIn, dblQuotedString, QuotedString, ParserElement )
+
++_noncomma = "".join( [ c for c in printables if c != "," ] )
+
+ class P_AttrList:
+