summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:15 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:15 +0200
commitee0173be9a357e05a3d50108752dbb5ee47cd3c7 (patch)
tree882da8dbd47cbf22f613b3cc708626fcead2c796 /media-gfx/rawtherapee
parentmedia-gfx/pngquant: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-ee0173be9a357e05a3d50108752dbb5ee47cd3c7.tar.gz
gentoo-ee0173be9a357e05a3d50108752dbb5ee47cd3c7.tar.bz2
gentoo-ee0173be9a357e05a3d50108752dbb5ee47cd3c7.zip
media-gfx/rawtherapee: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild8
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.8.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
index ea59ec8cbd19..6bc9d3808b2d 100644
--- a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
@@ -47,9 +47,11 @@ PATCHES=(
)
pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8.ebuild
index ef4b8c6fd287..9df073266f82 100644
--- a/media-gfx/rawtherapee/rawtherapee-5.8.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-5.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,9 +37,11 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {