summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-04-02 14:20:09 +0100
committerMatthew Smith <matthew@gentoo.org>2022-04-02 14:20:09 +0100
commit91d470f82468430f2eeceac809213ecd6be640ea (patch)
treebc81ae6d9b464fbc65162933dfc63c46333541bd /media-gfx/renderdoc
parentsci-libs/vtk: find qt binaries with qt-5.15.3 (diff)
downloadgentoo-91d470f82468430f2eeceac809213ecd6be640ea.tar.gz
gentoo-91d470f82468430f2eeceac809213ecd6be640ea.tar.bz2
gentoo-91d470f82468430f2eeceac809213ecd6be640ea.zip
media-gfx/renderdoc: fix build after qtchooser removal
Closes: https://bugs.gentoo.org/836474 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'media-gfx/renderdoc')
-rw-r--r--media-gfx/renderdoc/renderdoc-1.18-r2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-gfx/renderdoc/renderdoc-1.18-r2.ebuild b/media-gfx/renderdoc/renderdoc-1.18-r2.ebuild
index dde163f217a9..0673790fa460 100644
--- a/media-gfx/renderdoc/renderdoc-1.18-r2.ebuild
+++ b/media-gfx/renderdoc/renderdoc-1.18-r2.ebuild
@@ -13,7 +13,7 @@ AUTOTOOLS_AUTO_DEPEND="no"
DOCS_BUILDER="sphinx"
DOCS_DIR="docs"
PYTHON_COMPAT=( python3_{9,10} )
-inherit autotools cmake optfeature python-single-r1 docs xdg
+inherit autotools cmake optfeature python-single-r1 docs qmake-utils xdg
DESCRIPTION="A stand-alone graphics debugging tool"
HOMEPAGE="https://renderdoc.org https://github.com/baldurk/renderdoc"
@@ -167,6 +167,10 @@ src_configure() {
use qt5 && mycmakeargs+=(
-DPython3_EXECUTABLE="${PYTHON}"
-DRENDERDOC_SWIG_PACKAGE="${DISTDIR}"/${MY_SWIG}.tar.gz
+
+ # Needed after qtchooser removal, bug #836474.
+ -DQMAKE_QT5_COMMAND="$(qt5_get_bindir)"/qmake
+
-DQRENDERDOC_ENABLE_PYSIDE2=$(usex pyside2)
)