summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-09 21:43:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-09 21:43:38 +0200
commit4c4726e6eea23b45522cfee7bd28a0943f42f29b (patch)
tree0e949d516f3ff259e9fd4f035c8288dfa6a29d6d /media-gfx/ristretto/ristretto-0.10.0.ebuild
parentkde-apps/krfb: Fix missing header w/ future Frameworks (diff)
downloadgentoo-4c4726e6eea23b45522cfee7bd28a0943f42f29b.tar.gz
gentoo-4c4726e6eea23b45522cfee7bd28a0943f42f29b.tar.bz2
gentoo-4c4726e6eea23b45522cfee7bd28a0943f42f29b.zip
media-gfx/ristretto: Bump to 0.10.0, GTK+3 port
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/ristretto/ristretto-0.10.0.ebuild')
-rw-r--r--media-gfx/ristretto/ristretto-0.10.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/ristretto/ristretto-0.10.0.ebuild b/media-gfx/ristretto/ristretto-0.10.0.ebuild
new file mode 100644
index 000000000000..4fc93d04e8e5
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A fast and lightweight picture viewer for Xfce"
+HOMEPAGE="https://docs.xfce.org/apps/ristretto/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.42:2
+ media-libs/libexif:0=
+ sys-apps/file
+ x11-libs/cairo:0
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.10:0=
+ >=xfce-base/libxfce4util-4.10:0=
+ >=xfce-base/xfconf-4.12.1:0="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}