summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Davila <davila.luis.us@gmail.com>2021-12-10 17:20:57 -0800
committerSam James <sam@gentoo.org>2021-12-11 01:29:12 +0000
commit192e9b063f056d9f66d8e348d52a4d76b77538c7 (patch)
tree715080fc4d85900f9416a67892731ce925dcbcdc /media-gfx/scrot/scrot-1.7.ebuild
parentapp-emulation/libvirt: needs older Wireshark (diff)
downloadgentoo-192e9b063f056d9f66d8e348d52a4d76b77538c7.tar.gz
gentoo-192e9b063f056d9f66d8e348d52a4d76b77538c7.tar.bz2
gentoo-192e9b063f056d9f66d8e348d52a4d76b77538c7.zip
media-gfx/scrot: add 1.7
Closes: https://github.com/gentoo/gentoo/pull/23247 Signed-off-by: Luis Davila <davila.luis.us@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/scrot/scrot-1.7.ebuild')
-rw-r--r--media-gfx/scrot/scrot-1.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/scrot/scrot-1.7.ebuild b/media-gfx/scrot/scrot-1.7.ebuild
new file mode 100644
index 000000000000..9cad9ff4eae9
--- /dev/null
+++ b/media-gfx/scrot/scrot-1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libbsd
+ >=media-libs/giblib-1.2.3
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ || (
+ media-libs/imlib2[gif]
+ media-libs/imlib2[jpeg]
+ media-libs/imlib2[png]
+ media-libs/imlib2[tiff]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog README.md
+)
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+}