summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-11 01:27:18 +0000
committerSam James <sam@gentoo.org>2021-12-11 01:29:13 +0000
commitd914d68437908f21641c1a5f941ea8357d7ca67d (patch)
treeb339847802f03da12c79c5366591b29ba5b1bdf4 /media-gfx/scrot
parentmedia-gfx/scrot: add 1.7 (diff)
downloadgentoo-d914d68437908f21641c1a5f941ea8357d7ca67d.tar.gz
gentoo-d914d68437908f21641c1a5f941ea8357d7ca67d.tar.bz2
gentoo-d914d68437908f21641c1a5f941ea8357d7ca67d.zip
media-gfx/scrot: sync live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/scrot')
-rw-r--r--media-gfx/scrot/scrot-1.7.ebuild16
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild33
2 files changed, 36 insertions, 13 deletions
diff --git a/media-gfx/scrot/scrot-1.7.ebuild b/media-gfx/scrot/scrot-1.7.ebuild
index 9cad9ff4eae9..05091a934e05 100644
--- a/media-gfx/scrot/scrot-1.7.ebuild
+++ b/media-gfx/scrot/scrot-1.7.ebuild
@@ -7,11 +7,17 @@ inherit bash-completion-r1
DESCRIPTION="Screen capture utility using imlib2 library"
HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
-SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
LICENSE="feh LGPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
dev-libs/libbsd
@@ -40,6 +46,12 @@ DOCS=(
AUTHORS ChangeLog README.md
)
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
src_install() {
default
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
index 605a004b7102..05091a934e05 100644
--- a/media-gfx/scrot/scrot-9999.ebuild
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -1,19 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools bash-completion-r1 git-r3
+EAPI=8
+
+inherit bash-completion-r1
DESCRIPTION="Screen capture utility using imlib2 library"
HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
-EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
LICENSE="feh LGPL-2+"
SLOT="0"
-KEYWORDS=""
RDEPEND="
+ dev-libs/libbsd
>=media-libs/giblib-1.2.3
+ x11-libs/libXext
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXfixes
@@ -28,21 +37,23 @@ DEPEND="
${RDEPEND}
x11-base/xorg-proto
"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
DOCS=(
- AUTHORS ChangeLog CONTRIBUTING.md README.md TODO
+ AUTHORS ChangeLog README.md
)
src_prepare() {
- sed -i -e 's#-g -O3##g' src/Makefile.am || die
- cat "${FILESDIR}"/ax_prefix_config_h.m4 >> acinclude.m4 || die
-
default
- eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_install() {
default
- newbashcomp "${FILESDIR}"/${PN}-1.2.bash-completion ${PN}
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
}