summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-18 12:21:47 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-18 12:26:59 -0400
commit0c0b82d9fb8d66fe4ddefeba44f42f1428556d6b (patch)
tree9bdbe7c9049347385053d9840f13c3e393666455 /media-gfx/shotwell
parentsci-visualization/labplot: drop 2.8.2 (diff)
downloadgentoo-0c0b82d9fb8d66fe4ddefeba44f42f1428556d6b.tar.gz
gentoo-0c0b82d9fb8d66fe4ddefeba44f42f1428556d6b.tar.bz2
gentoo-0c0b82d9fb8d66fe4ddefeba44f42f1428556d6b.zip
media-gfx/shotwell: Version bump to 0.30.16
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.30.16.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 895ed3778370..41e5cafa6e09 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,2 +1,3 @@
DIST shotwell-0.30.14.tar.xz 6524680 BLAKE2B 321406d3731a4baa333c3820ee46e8dc12ca9a340c7f1ac3824ee894fa2826b7efa3ee7a27f551d62043e5f22199042befb5063cc67cefd27830e19db7d7f661 SHA512 bd899ac099ec4760f6119804812ef9314c9261c18273309abfb1dccc675b9e4a561c0abea1c46ea0dbbab9f5c00301d840b52714f97ec06548c180a77871db7c
DIST shotwell-0.30.15.tar.xz 6533632 BLAKE2B a973c22f06b2c05561db72974fa8f8a72006e4795ca282bd7c94e99f1b59c411917a30dd00b896cf606b80596c1510fe50e81c1a1c8fa6b98bcd75f8b25c5769 SHA512 aded4c8ec015546cb64189cc1a85b6bc233861367ec514cce041607a1deec9d69687f26e448865783c686813c1caec78df17c29d38c4296c4a255ff20c7cde0e
+DIST shotwell-0.30.16.tar.xz 6532812 BLAKE2B caa2ff2f4536d8f04900d7ba7c583b7ec0d0244d6253bc17971e2b4e04aa3790b17e932b3367e1be40d4a0bb566bab31396aa5dfdb6dbb5c9803272cd7f94e97 SHA512 4ed725a34b1663b9cb63dcd13c98795fb2ea9a5d79ee4541276bc9dc2f607ce6466cc9c983bab55e7418e69eef3d1598846aeb6750f00927663756bd11d9a084
diff --git a/media-gfx/shotwell/shotwell-0.30.16.ebuild b/media-gfx/shotwell/shotwell-0.30.16.ebuild
new file mode 100644
index 000000000000..ceecdaeb3d5c
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.30.16.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8
+ >=net-libs/webkit-gtk-2.26:4
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.10.4
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16:=
+ dev-libs/libgdata
+ >=app-crypt/gcr-3:=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-2.3.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:2.4[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity-support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ -Dextra-plugins=true
+ #trace
+ #measure
+ -Ddupe-detection=true
+ $(meson_use udev)
+ -Dinstall-apport-hook=false
+ $(meson_use opencv face-detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}