summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-12-17 19:47:18 +0200
committerMart Raudsepp <leio@gentoo.org>2021-12-17 19:48:03 +0200
commita0658e156d37df070621d9c49189289fcc26f9e8 (patch)
tree60d6f630b0d473c892025d2136260acbfcc109a0 /media-gfx/shotwell
parentapp-text/build-docbook-catalog: Stabilize 2.1 ppc, #829468 (diff)
downloadgentoo-a0658e156d37df070621d9c49189289fcc26f9e8.tar.gz
gentoo-a0658e156d37df070621d9c49189289fcc26f9e8.tar.bz2
gentoo-a0658e156d37df070621d9c49189289fcc26f9e8.zip
media-gfx/shotwell: fix compatibility with vala-0.52.8
Closes: https://bugs.gentoo.org/829261 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch13
-rw-r--r--media-gfx/shotwell/shotwell-0.30.14.ebuild5
2 files changed, 18 insertions, 0 deletions
diff --git a/media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch b/media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch
new file mode 100644
index 000000000000..0aef3e4eea96
--- /dev/null
+++ b/media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch
@@ -0,0 +1,13 @@
+diff --git a/src/dialogs/ExportDialog.vala b/src/dialogs/ExportDialog.vala
+index 5a61dc4a..c8011b7f 100644
+--- a/src/dialogs/ExportDialog.vala
++++ b/src/dialogs/ExportDialog.vala
+@@ -23,7 +23,7 @@ public class ExportDialog : Gtk.Dialog {
+
+ private static ScaleConstraint current_constraint = ScaleConstraint.ORIGINAL;
+ private static ExportFormatParameters current_parameters = ExportFormatParameters.current();
+- private static int current_scale = DEFAULT_SCALE;
++ private static int current_scale = 1200; //FIXME not needed with vala 0.54+
+
+ private Gtk.Grid table = new Gtk.Grid();
+ private Gtk.ComboBoxText quality_combo;
diff --git a/media-gfx/shotwell/shotwell-0.30.14.ebuild b/media-gfx/shotwell/shotwell-0.30.14.ebuild
index 629bc8a3d4c2..d0ee07286e10 100644
--- a/media-gfx/shotwell/shotwell-0.30.14.ebuild
+++ b/media-gfx/shotwell/shotwell-0.30.14.ebuild
@@ -50,6 +50,11 @@ BDEPEND="
app-crypt/gcr[vala]
"
+PATCHES=(
+ # Fix build against vala-0.52.8. Isn't needed once we use 0.54+ or drop vala:0.52 slots
+ "${FILESDIR}"/${PV}-vala-0.52.8-compat.patch
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare