summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild')
-rw-r--r--media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild b/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild
new file mode 100644
index 000000000000..df633601bb74
--- /dev/null
+++ b/media-gfx/splash-themes-gentoo/splash-themes-gentoo-20101212-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A collection of Gentoo themes for splashutils"
+HOMEPAGE="http://dev.gentoo.org/~spock/"
+SRC_URI="mirror://gentoo/fbsplash-theme-emergence-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-gentoo-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-emerge-world-1.0.tar.bz2
+ http://fbsplash.berlios.de/themes/repo/natural_gentoo-9.0-r2.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=media-gfx/splashutils-1.1.9.5[png]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ sed -i -e 's/natural-gentoo/natural_gentoo/g' natural_gentoo/*.cfg || die 'sed failed'
+}
+
+src_install() {
+ insinto /etc/splash
+ doins -r *
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The upstream tarball for the 'Natural Gentoo' theme also contains a GRUB"
+ elog "splash image which is not installed by this ebuild. See:"
+ elog " http://www.kde-look.org/content/show.php?content=49074"
+ elog "if you are interested in this."
+ fi
+}