summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/springgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/springgraph')
-rw-r--r--media-gfx/springgraph/Manifest2
-rw-r--r--media-gfx/springgraph/metadata.xml14
-rw-r--r--media-gfx/springgraph/springgraph-88.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/springgraph/Manifest b/media-gfx/springgraph/Manifest
new file mode 100644
index 000000000000..a44fba0f5336
--- /dev/null
+++ b/media-gfx/springgraph/Manifest
@@ -0,0 +1,2 @@
+DIST springgraph.pl.88 29818 SHA256 7e9eac0301d93a0f3e63e7a2ebd305434195313497e81574fced9ce3114ccd3f
+DIST springgraph_0.82-5.diff.gz 3110 SHA256 6085f6037b6c7a4c2b1ad4449e1c6b68502e40a172b1c7626d939811e3e3d22f
diff --git a/media-gfx/springgraph/metadata.xml b/media-gfx/springgraph/metadata.xml
new file mode 100644
index 000000000000..1f8a87a2f6dd
--- /dev/null
+++ b/media-gfx/springgraph/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription> Springgraph will read in a .dot file description of a graph,
+ which, for each node, specifies its name and which other nodes it is
+ connected to, and then renders a graph. Each node is drawn as an ellipse,
+ and each connection is drawn as an arrow. The node placement is a result of
+ all of the nodes moving away from each other, while all nodes which are
+ connected move toward each other. This movement is repeated until it
+ stabilizes.</longdescription>
+</pkgmetadata>
diff --git a/media-gfx/springgraph/springgraph-88.ebuild b/media-gfx/springgraph/springgraph-88.ebuild
new file mode 100644
index 000000000000..d0780ac92dcb
--- /dev/null
+++ b/media-gfx/springgraph/springgraph-88.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Generate spring graphs from graphviz input files"
+HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
+MY_PV="0.${PV}"
+MY_P="${PN}_${MY_PV}"
+SRC_FILE="${MY_P}.orig.tar.gz"
+SRC_DEBIAN_PATCH="${PN}_0.82-5.diff.gz"
+SRC_URI="http://www.chaosreigns.com/code/springgraph/dl/${PN}.pl.${PV}
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ~ppc64 sparc x86"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-perl/GD"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ mkdir -p ${S}
+ cp ${DISTDIR}/${PN}.pl.${PV} ${S}/${PN}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${DISTDIR}/${SRC_DEBIAN_PATCH}
+}
+
+src_compile() {
+ # nothing to do
+ :
+}
+
+src_install() {
+ into /usr
+ dobin ${PN}
+ doman debian/${PN}.1
+}