summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/sxiv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/sxiv/files')
-rw-r--r--media-gfx/sxiv/files/sxiv-1.1-makefile.patch14
-rw-r--r--media-gfx/sxiv/files/sxiv-1.2-makefile.patch16
-rw-r--r--media-gfx/sxiv/files/sxiv-1.3-makefile.patch30
3 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/sxiv/files/sxiv-1.1-makefile.patch b/media-gfx/sxiv/files/sxiv-1.1-makefile.patch
new file mode 100644
index 000000000000..159173d2ff81
--- /dev/null
+++ b/media-gfx/sxiv/files/sxiv-1.1-makefile.patch
@@ -0,0 +1,14 @@
+--- sxiv-1.1/Makefile
++++ sxiv-1.1/Makefile
+@@ -3,9 +3,8 @@
+ PREFIX = /usr/local
+ MANPREFIX = $(PREFIX)/share/man
+
+-CC = gcc
+-CFLAGS = -std=c99 -Wall -pedantic -O2 -I$(PREFIX)/include -DHAVE_GIFLIB
+-LDFLAGS = -L$(PREFIX)/lib
++CC ?= gcc
++CFLAGS += -std=c99 -Wall -pedantic -DHAVE_GIFLIB
+ LIBS = -lX11 -lImlib2 -lgif
+
+ SRC = commands.c exif.c image.c main.c options.c thumbs.c util.c window.c
diff --git a/media-gfx/sxiv/files/sxiv-1.2-makefile.patch b/media-gfx/sxiv/files/sxiv-1.2-makefile.patch
new file mode 100644
index 000000000000..333f4cd54b24
--- /dev/null
+++ b/media-gfx/sxiv/files/sxiv-1.2-makefile.patch
@@ -0,0 +1,16 @@
+--- sxiv-1.2/Makefile
++++ sxiv-1.2/Makefile
+@@ -3,10 +3,9 @@
+ PREFIX = /usr/local
+ MANPREFIX = $(PREFIX)/share/man
+
+-CC = gcc
+-CFLAGS = -std=c99 -Wall -pedantic -O2
+-CPPFLAGS = -I$(PREFIX)/include -D_XOPEN_SOURCE=500 -DHAVE_GIFLIB
+-LDFLAGS = -L$(PREFIX)/lib
++CC ?= gcc
++CFLAGS += -std=c99 -Wall -pedantic -O2
++CPPFLAGS += -D_XOPEN_SOURCE=500 -DHAVE_GIFLIB
+ LIBS = -lX11 -lImlib2 -lgif
+
+ SRC = commands.c exif.c image.c main.c options.c thumbs.c util.c window.c
diff --git a/media-gfx/sxiv/files/sxiv-1.3-makefile.patch b/media-gfx/sxiv/files/sxiv-1.3-makefile.patch
new file mode 100644
index 000000000000..0640bf71af92
--- /dev/null
+++ b/media-gfx/sxiv/files/sxiv-1.3-makefile.patch
@@ -0,0 +1,30 @@
+--- sxiv-1.3/Makefile
++++ sxiv-1.3/Makefile
+@@ -3,10 +3,9 @@
+ PREFIX = /usr/local
+ MANPREFIX = $(PREFIX)/share/man
+
+-CC = gcc
+-CFLAGS = -std=c99 -Wall -pedantic -O2
+-CPPFLAGS = -I$(PREFIX)/include -D_XOPEN_SOURCE=500 -DHAVE_LIBEXIF -DHAVE_GIFLIB
+-LDFLAGS = -L$(PREFIX)/lib
++CC ?= gcc
++CFLAGS += -std=c99 -Wall -pedantic
++CPPFLAGS += -I$(PREFIX)/include -D_XOPEN_SOURCE=500 -DHAVE_LIBEXIF -DHAVE_GIFLIB
+ LIBS = -lX11 -lImlib2 -lexif -lgif
+
+ SRC = commands.c image.c main.c options.c thumbs.c util.c window.c
+@@ -18,11 +17,11 @@
+
+ depend: .depend
+
+-.depend: $(SRC)
++.depend: $(SRC) config.h
+ rm -f ./.depend
+ $(CC) $(CFLAGS) -MM $^ >./.depend
+
+-include .depend
++-include .depend
+
+ .c.o:
+ $(CC) $(CFLAGS) $(CPPFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<