summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-04 19:15:16 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-04 19:30:37 +0100
commit9e76d4fdf84a704c6f3397ae0e1a4a18dcafac80 (patch)
tree8f49fa38802560294c8a75b037d330a2a4e4b26d /media-gfx/synnefo/synnefo-1.1.0.ebuild
parentapp-text/xmlto: disable text USE flag by default (diff)
downloadgentoo-9e76d4fdf84a704c6f3397ae0e1a4a18dcafac80.tar.gz
gentoo-9e76d4fdf84a704c6f3397ae0e1a4a18dcafac80.tar.bz2
gentoo-9e76d4fdf84a704c6f3397ae0e1a4a18dcafac80.zip
media-gfx/synnefo: New package
Import from kde overlay. Initial ebuild by Andreas Sturmlechner. Improvements by him and me. Needed for kde-misc/kolor-manager:5. Gentoo-bug: 603552 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-gfx/synnefo/synnefo-1.1.0.ebuild')
-rw-r--r--media-gfx/synnefo/synnefo-1.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/synnefo/synnefo-1.1.0.ebuild b/media-gfx/synnefo/synnefo-1.1.0.ebuild
new file mode 100644
index 000000000000..db603634f4fe
--- /dev/null
+++ b/media-gfx/synnefo/synnefo-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/oyranos-cms/Synnefo.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/oyranos-cms/Synnefo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/Synnefo-${PV}"
+fi
+
+DESCRIPTION="Qt front end for the Oyranos Color Management System"
+HOMEPAGE="https://github.com/oyranos-cms/Synnefo"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=media-libs/oyranos-0.9.6
+"
+RDEPEND="${DEPEND}
+ x11-misc/xcalib
+"
+
+DOCS=( AUTHORS.md README.md )