summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 12:41:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 12:58:38 +0100
commit2e165d78d72d1afb4216c4983f7c16d22c3911c7 (patch)
tree009fd6530f6d58fb29bfed424b12c3370d4a667c /media-gfx/termtosvg
parentdev-python/sphinxcontrib-doxylink: Enable py3.11 (diff)
downloadgentoo-2e165d78d72d1afb4216c4983f7c16d22c3911c7.tar.gz
gentoo-2e165d78d72d1afb4216c4983f7c16d22c3911c7.tar.bz2
gentoo-2e165d78d72d1afb4216c4983f7c16d22c3911c7.zip
media-gfx/termtosvg: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/termtosvg')
-rw-r--r--media-gfx/termtosvg/termtosvg-1.1.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/termtosvg/termtosvg-1.1.0-r1.ebuild b/media-gfx/termtosvg/termtosvg-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..57ddbbfdd0e0
--- /dev/null
+++ b/media-gfx/termtosvg/termtosvg-1.1.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Record terminal sessions as SVG animations"
+HOMEPAGE="https://github.com/nbedos/termtosvg"
+SRC_URI="https://github.com/nbedos/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/pyte-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest