summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-01-08 00:17:24 +0100
committerSam James <sam@gentoo.org>2022-01-16 01:33:23 +0000
commitc8ebeb61ccd1041ea4f0a5ba5d74c2693efa2c7b (patch)
tree22baf2f7fc8e76f2cb1ed496de760ff628807caa /media-gfx/tuxpaint
parentsci-libs/opencascade: revbump for fixed USE_OPENGL option in 7.6.x (diff)
downloadgentoo-c8ebeb61ccd1041ea4f0a5ba5d74c2693efa2c7b.tar.gz
gentoo-c8ebeb61ccd1041ea4f0a5ba5d74c2693efa2c7b.tar.bz2
gentoo-c8ebeb61ccd1041ea4f0a5ba5d74c2693efa2c7b.zip
media-gfx/tuxpaint: version bump to 0.9.27
We added an ebuild for tuxpaint-0.9.27. We also added support for EAPI 8, added necessary dependencies and did minor cleanup. Closes: https://bugs.gentoo.org/767223 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Philipp Roesner <rndxelement@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/tuxpaint')
-rw-r--r--media-gfx/tuxpaint/Manifest1
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.27.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-gfx/tuxpaint/Manifest b/media-gfx/tuxpaint/Manifest
index 9a3f246ba0d6..9670ea86fc54 100644
--- a/media-gfx/tuxpaint/Manifest
+++ b/media-gfx/tuxpaint/Manifest
@@ -1 +1,2 @@
DIST tuxpaint-0.9.24.tar.gz 15561675 BLAKE2B 971baec8b7728cbb54a2a45b604c152a9620d0f6a1856cca99482ad0fd76f2a4493aab81f54e10e5da4d81800b0e3506cb73dda0e00510ef966b0c98f8aa5cb4 SHA512 a4ee9eea833f9a6313701a4686f9f276570df84436c68d9a3d04e9448a8ea00833207e1034965e15145be744194c7b9a7d3c91bdfa3489d06a61de84b64cc723
+DIST tuxpaint-0.9.27.tar.gz 14292992 BLAKE2B f1337b828604bac968325437eba21046f871a0e07e049f2d3568f44adac400e729f4c6d46bcba9eddf9078089aaf55aab7d0774fb5ab126b96d317b59e37ee00 SHA512 197c6e23fb772edd57614e34dec23e160ece528b58e4a17d67fe4100c58cbcd6c4b5efccfbb24ca760b3a20755230b47f4e3e49969e75ba04ce722102a7f2dd9
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.27.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.27.ebuild
new file mode 100644
index 000000000000..9fbfe4c29e7b
--- /dev/null
+++ b/media-gfx/tuxpaint/tuxpaint-0.9.27.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature toolchain-funcs xdg
+
+DESCRIPTION="Drawing program designed for young children"
+HOMEPAGE="http://www.tuxpaint.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ app-text/libpaper
+ dev-libs/fribidi
+ gnome-base/librsvg:2
+ media-gfx/libimagequant
+ >=media-libs/libpng-1.2:0=
+ >=media-libs/freetype-2:2
+ media-libs/libsdl[joystick]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ x11-libs/cairo
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gperf
+ virtual/imagemagick-tools
+ sys-devel/gettext
+"
+
+src_prepare() {
+
+ sed -i \
+ -e 's|linux_ARCH_INSTALL:=install-xdg|linux_ARCH_INSTALL:=|' \
+ -e "s|linux_PREFIX:=/usr/local|linux_PREFIX:=/usr|" \
+ -e "s:/lib/:/$(get_libdir)/:g" \
+ -e 's:/share/doc/tuxpaint-$(VER_VERSION)/:'"/share/doc/${PF}/:g" \
+ -e '/@gzip -f/d' \
+ -e '/@chmod a+rx,g-w,o-w $(MAN_PREFIX)/d' \
+ -e "s|linux_ARCH_CFLAGS:=|linux_ARCH_CFLAGS:= ${CFLAGS}|" \
+ Makefile || die
+
+ eapply_user
+}
+
+src_compile() {
+ # parallel build may break things
+ emake -j1 CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ local file size
+ for file in data/images/icon[0-9]*x[0-9]*.png; do
+ size=${file##*/icon}
+ size=${size%%x*}
+ newicon -s "${size}" "${file}" tux4kids-tuxpaint.png
+ done
+ newmenu src/tuxpaint.desktop tux4kids-tuxpaint.desktop
+ dodoc docs/*.txt
+ dodoc docs/en/*.txt
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "additional graphic stamps" media-gfx/tuxpaint-stamps
+}