summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-11 00:02:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-11 04:32:35 -0400
commit3cf55884154c50efecececbe1d75bd43f7b0a98d (patch)
tree19f9e8ee8814968e80c3c9cc5b86f5d0fea81f30 /media-gfx/ueberzugpp
parentdev-util/jenkins-bin: drop 2.440.1, 2.440.2, 2.446 (diff)
downloadgentoo-3cf55884154c50efecececbe1d75bd43f7b0a98d.tar.gz
gentoo-3cf55884154c50efecececbe1d75bd43f7b0a98d.tar.bz2
gentoo-3cf55884154c50efecececbe1d75bd43f7b0a98d.zip
media-gfx/ueberzugpp: add 2.9.5
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/ueberzugpp')
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index e49d5e6986a0..654a26a0ca94 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1 +1,2 @@
DIST ueberzugpp-2.9.4.tar.gz 67825 BLAKE2B 185919717cbbe97b98a44c2b91e244cf72bd760033b1a9d82e0d2f06db1d9b6d57557f57f4cedec8408d61e16658e90977569a63eb17a38afb36b134ff21889b SHA512 3d47874ecde4cc9030490c878851a21d94554538200ba41e87dd9f3aa760a6ed511aad573b820798492a82e4c49219cd4cdc79f5c99c6a80c322d09e618f82a6
+DIST ueberzugpp-2.9.5.tar.gz 69268 BLAKE2B 9a31c7d5135ca0c5b85e250f9cbb5fb10e22344a7c6bf5393a04ec928580844470b24b0471aa609a83a0f1cbfed17944aabdec9ee5d6ddffe90720fa46bf80ad SHA512 43576ba504ec66a909c170122db808a8ae55535d54cad09172590af2790c981b1bfba6ba0f749a5ca9881a15cfdcdb0c34fbb2533f72011a786fd1413d1f91c4
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild
new file mode 100644
index 000000000000..d3d4f397c2d9
--- /dev/null
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.9.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic toolchain-funcs
+
+DESCRIPTION="Drop in replacement for ueberzug written in C++"
+HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
+SRC_URI="
+ https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X dbus opencv opengl wayland xcb-errors"
+REQUIRED_USE="xcb-errors? ( X )"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ media-gfx/chafa
+ media-libs/libsixel
+ media-libs/vips:=
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ )
+ dbus? ( sys-apps/dbus )
+ opencv? ( media-libs/opencv:= )
+ opengl? ( media-libs/libglvnd )
+ wayland? ( dev-libs/wayland )
+ !media-gfx/ueberzug
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cli11
+ dev-cpp/nlohmann_json
+ dev-cpp/range-v3
+ X? ( x11-base/xorg-proto )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+src_configure() {
+ if use X && tc-is-clang && has_version sys-libs/libcxx; then
+ # X support makes use of C++20's std::jthread which is currently
+ # marked experimental (at least) in <=libcxx-18 (should limit
+ # version in above libcxx check whenever this becomes unnecessary)
+ append-cxxflags $(test-flags-CXX -fexperimental-library)
+ fi
+
+ # TODO?: wayfire plugin is skipped for now (needs wlroots which is
+ # likely to be messier), but could be handled if there is a demand
+
+ local mycmakeargs=(
+ -DENABLE_DBUS=$(usex dbus)
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_OPENGL=$(usex opengl)
+ -DENABLE_TURBOBASE64=no # not packaged
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_XCB_ERRORS=$(usex xcb-errors)
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}