summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-28 17:01:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-28 17:44:39 -0400
commit3e159a1617484b183e187a718f434135fa7fb8bd (patch)
treedac5c64437b21da13c61c9088f69703b2191c194 /media-gfx/ueberzugpp
parentnet-dialup/ppp: fix pidfile path (diff)
downloadgentoo-3e159a1617484b183e187a718f434135fa7fb8bd.tar.gz
gentoo-3e159a1617484b183e187a718f434135fa7fb8bd.tar.bz2
gentoo-3e159a1617484b183e187a718f434135fa7fb8bd.zip
media-gfx/ueberzugpp: rename sway USE to wayland
It is still not generic wayland support, but it now supports hyprland on top of sway and the generic flag may be ok with just local description to clarify. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/ueberzugpp')
-rw-r--r--media-gfx/ueberzugpp/metadata.xml2
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild10
2 files changed, 6 insertions, 6 deletions
diff --git a/media-gfx/ueberzugpp/metadata.xml b/media-gfx/ueberzugpp/metadata.xml
index 407eee6aebee..3099100a6dd7 100644
--- a/media-gfx/ueberzugpp/metadata.xml
+++ b/media-gfx/ueberzugpp/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<use>
<flag name="opencv">Use <pkg>media-libs/opencv</pkg> for additional image formats and OpenCL accelerated scaling</flag>
- <flag name="sway">Enable support for <pkg>gui-wm/sway</pkg> on wayland</flag>
+ <flag name="wayland">Enable wayland support (only usable with some wlroots-based compositors)</flag>
</use>
<upstream>
<remote-id type="github">jstkdng/ueberzugpp</remote-id>
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild
index 3d6109418aae..076a995df926 100644
--- a/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz -
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="X opencv sway"
+IUSE="X opencv wayland"
RDEPEND="
dev-cpp/tbb:=
@@ -29,7 +29,7 @@ RDEPEND="
x11-libs/xcb-util-image
)
opencv? ( media-libs/opencv:= )
- sway? ( dev-libs/wayland )
+ wayland? ( dev-libs/wayland )
!media-gfx/ueberzug"
DEPEND="
${RDEPEND}
@@ -37,9 +37,9 @@ DEPEND="
dev-cpp/ms-gsl
dev-cpp/nlohmann_json
X? ( x11-base/xorg-proto )
- sway? ( dev-libs/wayland-protocols )"
+ wayland? ( dev-libs/wayland-protocols )"
BDEPEND="
- sway? (
+ wayland? (
dev-util/wayland-scanner
kde-frameworks/extra-cmake-modules
)"
@@ -49,7 +49,7 @@ src_configure() {
local mycmakeargs=(
-DENABLE_OPENCV=$(usex opencv)
- -DENABLE_SWAY=$(usex sway)
+ -DENABLE_SWAY=$(usex wayland)
-DENABLE_TURBOBASE64=no # not packaged
-DENABLE_X11=$(usex X)
-DFETCHCONTENT_FULLY_DISCONNECTED=yes