summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-19 06:47:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-19 06:47:12 -0400
commit418493c1d82e3670132ac4e58da6a7aab04edaf0 (patch)
treeaf2aa1ed09c9a5eaff4fd0fa0c7d1258b12aa3b2 /media-gfx/ueberzugpp
parentmedia-gfx/ueberzugpp: drop 2.8.9 (diff)
downloadgentoo-418493c1d82e3670132ac4e58da6a7aab04edaf0.tar.gz
gentoo-418493c1d82e3670132ac4e58da6a7aab04edaf0.tar.bz2
gentoo-418493c1d82e3670132ac4e58da6a7aab04edaf0.zip
media-gfx/ueberzugpp: add 2.9.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/ueberzugpp')
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.9.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index 81fcd54bbac1..432246b4c6cc 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1 +1,2 @@
DIST ueberzugpp-2.9.0.tar.gz 65829 BLAKE2B 55498b49077e2a85546d251efd082b67f811513d87064bb907e29ec5f4b72a22ed9c85be7296a5a9594fe1c520041c61b458acc96ac6f187106079b3429ace37 SHA512 4b21565a8ed2874f966fd5618fc043932dd9b310812be0e36b9c6548af11b773ca2d2977458ddd50db70e0fbe2d603c408480c5982e9538220c8c7173d30e6b2
+DIST ueberzugpp-2.9.1.tar.gz 65961 BLAKE2B a7aa8536d15d992004ffd783b0b87ec57528b4a6b6e24d0d63588d74436e055d1ed37d36683f663c35809d6e84b7b9dca11c660c64a11c9ca0125cae0dfba2a3 SHA512 a1dadf4cbbd602edbff88855289b6d4a75093fa7d6130c90affb2c54ca71866d73b0d2be3acaa40c1459165609f08511ffb507e0ee7ae09363c97d69a4bad879
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.9.1.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.9.1.ebuild
new file mode 100644
index 000000000000..828290c2ec13
--- /dev/null
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.9.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Drop in replacement for ueberzug written in C++"
+HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
+SRC_URI="
+ https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X opencv opengl wayland xcb-errors"
+REQUIRED_USE="xcb-errors? ( X )"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ media-gfx/chafa
+ media-libs/libsixel
+ media-libs/vips:=
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ )
+ opencv? ( media-libs/opencv:= )
+ opengl? ( media-libs/libglvnd )
+ wayland? ( dev-libs/wayland )
+ !media-gfx/ueberzug
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cli11
+ dev-cpp/ms-gsl
+ dev-cpp/nlohmann_json
+ X? ( x11-base/xorg-proto )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+src_configure() {
+ # TODO?: wayfire plugin is skipped for now (needs wlroots which is
+ # likely to be messier), but could be handled if there is a demand
+
+ local mycmakeargs=(
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_OPENGL=$(usex opengl)
+ -DENABLE_TURBOBASE64=no # not packaged
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_XCB_ERRORS=$(usex xcb-errors)
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}