summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-25 00:37:07 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-25 00:37:55 +0100
commit7595febb854183eb9331903d6d443db0f4e57a06 (patch)
tree8e5502206d6e6d233888586e9115196f175d7ac9 /media-gfx/videorbits/files
parentdev-python/pychroot: remove unnecessary man page conditional (diff)
downloadgentoo-7595febb854183eb9331903d6d443db0f4e57a06.tar.gz
gentoo-7595febb854183eb9331903d6d443db0f4e57a06.tar.bz2
gentoo-7595febb854183eb9331903d6d443db0f4e57a06.zip
media-gfx/videorbits: Version bump to 2.205
Gentoo-Bug: 570302 * EAPI=6 * Make patch -p1 compatible * Add missing sci-libs/fftw:2.1 dependency * Add missing media-libs/netpbm dependency * Fix -Werror=format-security errors * Fix QA implicit declarations Package-Manager: portage-2.2.27
Diffstat (limited to 'media-gfx/videorbits/files')
-rw-r--r--media-gfx/videorbits/files/videorbits-2.201-libpng15.patch8
-rw-r--r--media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch19
-rw-r--r--media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch23
3 files changed, 46 insertions, 4 deletions
diff --git a/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
index e384738b9357..f87132b0be44 100644
--- a/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
+++ b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
@@ -1,5 +1,5 @@
---- src/simple_png_read.c
-+++ src/simple_png_read.c
+--- videorbits-2.205/src/simple_png_read.c
++++ videorbits-2.205/src/simple_png_read.c
@@ -92,7 +92,7 @@
return -1;
}
@@ -18,8 +18,8 @@
fprintf(stderr, "simple_png_read_header: error\n");
png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
fclose(fp);
---- src/simple_png_write.c
-+++ src/simple_png_write.c
+--- videorbits-2.205/src/simple_png_write.c
++++ videorbits-2.205/src/simple_png_write.c
@@ -18,6 +18,7 @@
#include <stdio.h>
#include <stdlib.h>
diff --git a/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch b/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch
new file mode 100644
index 000000000000..8d2359232bc2
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch
@@ -0,0 +1,19 @@
+Fix installation paths.
+
+--- videorbits-2.205/images/Makefile.am
++++ videorbits-2.205/images/Makefile.am
+@@ -1,4 +1,4 @@
+-imagesdir = $(prefix)/images
+-images_DATA= v04.pgm v06.pgm
++images_dir = $(datadir)/videorbits/images
++images__DATA= v04.pgm v06.pgm
+
+
+--- videorbits-2.205/lookuptables/Makefile.am
++++ videorbits-2.205/lookuptables/Makefile.am
+@@ -1,3 +1,3 @@
+-lookuptablesdir = $(prefix)/lookuptables
+-lookuptables_DATA=powLookup22.txt powLookup47.txt Kodak_DCS260_response_function
++lookuptables_dir = $(datadir)/videorbits/lookuptables
++lookuptables__DATA=powLookup22.txt powLookup47.txt Kodak_DCS260_response_function
+
diff --git a/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch b/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch
new file mode 100644
index 000000000000..1e46ccf5651e
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch
@@ -0,0 +1,23 @@
+Fix implicit declarations caused by missing headers and
+failures caused by -Werror=format-security checks
+
+--- videorbits-2.205/src/pchirp2nocrop.c
++++ videorbits-2.205/src/pchirp2nocrop.c
+@@ -1,5 +1,6 @@
+ #include <stdlib.h>
+ #include <math.h>
++#include <string.h>
+ #include "PNMImageOffsetable.h"
+ #include "mat_util.h"
+ #include "boundingbox.h"
+--- videorbits-2.205/src/par.c
++++ videorbits-2.205/src/par.c
+@@ -111,7 +111,7 @@
+
+ /* - - Write file-type number - - */
+ sprintf(magic_number, "P%d\n", data_type);
+- fprintf(file_ptr, magic_number);
++ fprintf(file_ptr, "%s", magic_number);
+
+ /* - - put comments - - */ /* !!!!!! break up long comments */
+ fprintf(file_ptr, "# %s\n", comments);