summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-17 10:56:20 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-17 10:58:32 +0200
commit5f674bbab87e63a33c22ae2c591aed3b8ee9492b (patch)
tree6330b73963b762ece7bcdf0bd9e5a460317b32e4 /media-gfx/wings/wings-2.2.6.1.ebuild
parentmedia-fonts/cascadia-code: keyworded 1910.04 for ia64, bug #696894 (diff)
downloadgentoo-5f674bbab87e63a33c22ae2c591aed3b8ee9492b.tar.gz
gentoo-5f674bbab87e63a33c22ae2c591aed3b8ee9492b.tar.bz2
gentoo-5f674bbab87e63a33c22ae2c591aed3b8ee9492b.zip
media-gfx/wings: Version 2.2.6.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'media-gfx/wings/wings-2.2.6.1.ebuild')
-rw-r--r--media-gfx/wings/wings-2.2.6.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-gfx/wings/wings-2.2.6.1.ebuild b/media-gfx/wings/wings-2.2.6.1.ebuild
new file mode 100644
index 000000000000..81caee71f2ed
--- /dev/null
+++ b/media-gfx/wings/wings-2.2.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wings 3D is an advanced subdivision modeler"
+HOMEPAGE="http://www.wings3d.com/"
+SRC_URI="mirror://sourceforge/wings/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ <dev-lang/erlang-21[smp,wxwidgets]
+ >dev-lang/erlang-21[wxwidgets]
+ )
+ dev-libs/cl
+ media-libs/glu
+ media-libs/libsdl[opengl]
+ virtual/opengl
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_compile() {
+ export ERL_PATH="/usr/$(get_libdir)/erlang/lib/"
+ # Work around parallel make issues
+ # Set ER_LIBS to the top source directory
+ emake vsn.mk
+ for subdir in intl_tools e3d src plugins_src icons; do
+ emake -C ${subdir} opt ERL_LIBS="${S}"
+ done
+ default
+}
+
+src_install() {
+ WINGS_PATH=${ERL_PATH}/${P}
+ dodir ${WINGS_PATH}
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+
+ insinto ${WINGS_PATH}
+ doins -r e3d ebin icons plugins priv psd shaders src textures tools
+
+ newbin "${FILESDIR}"/wings.sh-r1 wings
+ dodoc AUTHORS README
+}