summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-07 01:12:38 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-07 01:14:06 -0500
commitcc361de7214af32e8219b11cc98eee5e03ff4224 (patch)
tree099dcf22ff51c7cb282a81af36f0372ea80d77e6 /media-gfx/xdot/xdot-0.5.ebuild
parentdev-ruby/textpow: add ruby23 (diff)
downloadgentoo-cc361de7214af32e8219b11cc98eee5e03ff4224.tar.gz
gentoo-cc361de7214af32e8219b11cc98eee5e03ff4224.tar.bz2
gentoo-cc361de7214af32e8219b11cc98eee5e03ff4224.zip
media-gfx/xdot: add xdot-0.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-gfx/xdot/xdot-0.5.ebuild')
-rw-r--r--media-gfx/xdot/xdot-0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/xdot/xdot-0.5.ebuild b/media-gfx/xdot/xdot-0.5.ebuild
new file mode 100644
index 000000000000..c31d3d673d00
--- /dev/null
+++ b/media-gfx/xdot/xdot-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=xdot.py
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interactive viewer for Graphviz dot files"
+HOMEPAGE="https://github.com/jrfonseca/xdot.py"
+SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-gfx/graphviz[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"