summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/xzgv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/xzgv/files')
-rw-r--r--media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch b/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch
new file mode 100644
index 000000000000..8b3c671dbf8a
--- /dev/null
+++ b/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch
@@ -0,0 +1,35 @@
+http://bugs.gentoo.org/500692
+
+--- config.mk
++++ config.mk
+@@ -7,7 +7,7 @@
+ # This is likely to be what you'll want for most systems:
+ #
+ CC=gcc
+-CFLAGS=-O2 -Wall
++CFLAGS+=-Wall
+
+ # Set the awk interpreter to use for a script used while compiling.
+ # (This should be a `new' awk, such as gawk or mawk.)
+--- src/Makefile
++++ src/Makefile
+@@ -9,8 +9,8 @@
+ # This gets definitions for CC, CFLAGS, BINDIR etc.
+ include ../config.mk
+
+-CFLAGS+=`pkg-config --cflags gtk+-2.0` `pkg-config --cflags gdk-pixbuf-2.0`
+-LDFLAGS+=`pkg-config --libs gtk+-2.0` `pkg-config --libs gdk-pixbuf-2.0`
++CFLAGS+=`pkg-config --cflags gtk+-2.0` `pkg-config --cflags gdk-pixbuf-2.0` `pkg-config --cflags x11`
++LIBS=`pkg-config --libs gtk+-2.0` `pkg-config --libs gdk-pixbuf-2.0` `pkg-config --libs x11` -lm
+
+ all: xzgv
+
+@@ -23,7 +23,7 @@
+ backend.o
+
+ xzgv: $(OBJS)
+- $(CC) $(LDFLAGS) -o xzgv $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o xzgv
+
+ installdirs:
+ /bin/sh ../mkinstalldirs $(BINDIR)