summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-23 18:07:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-23 18:10:06 -0400
commit03808cb195486406366f412b2e38ff0d6623597b (patch)
treeaea976d018a39d9b35854901637b6c2c05ed99bc /media-gfx
parentmedia-gfx/ueberzugpp: drop 2.8.4, 2.8.6 (diff)
downloadgentoo-03808cb195486406366f412b2e38ff0d6623597b.tar.gz
gentoo-03808cb195486406366f412b2e38ff0d6623597b.tar.bz2
gentoo-03808cb195486406366f412b2e38ff0d6623597b.zip
media-gfx/ueberzugpp: add 2.8.8 (unkeyworded)
Kitty backend that I use still works, but something seems to have broken use with ytfzf when using X (2.8.7 still works). Haven't investigated yet, so just adding unkeyworded for testing. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/metadata.xml1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.8.8.ebuild62
3 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index 4e897ce23354..4965100cf7e2 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1 +1,2 @@
DIST ueberzugpp-2.8.7.tar.gz 53658 BLAKE2B 7d6c8ea082360f98bcce90cdc0eb0d8c5fc6e4765eece225be778c07f1cf91e6550e2c74b75f4edb1eaa8eaf5fd1861493c05610343693aafc428adb1d784fda SHA512 e418576f1c01919cd8997d8bcc4169405ef85f6ae74f28790e37a1ad82bbdb1ee3296396243e5ea9d3b99ffb40a9608d0345c51650cbb4b097191c3ce64f578d
+DIST ueberzugpp-2.8.8.tar.gz 56141 BLAKE2B 9faea08c400822db86ea3963c653581e9ab8ec76989107cd072df8071ba238395a57fd820d3dc9a51d55e1820adbd7c67dc0dcce9a60aab3596e885bb1d15f50 SHA512 4354d00a3d07ddb68132a0581aeec182fce61873123d2a78f32d83db3c0227be80c5430b00bebcbda863e8fc23a35d65247a463d3f411ea09ad7b9d6cff39f92
diff --git a/media-gfx/ueberzugpp/metadata.xml b/media-gfx/ueberzugpp/metadata.xml
index 8728c0dd5768..fc6c73e0ed27 100644
--- a/media-gfx/ueberzugpp/metadata.xml
+++ b/media-gfx/ueberzugpp/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="opencv">Use <pkg>media-libs/opencv</pkg> for additional image formats and OpenCL accelerated scaling</flag>
<flag name="wayland">Enable wayland support (proper window positioning is only supported with some compositors)</flag>
+ <flag name="xcb-errors">Use <pkg>x11-libs/xcb-util-errors</pkg> for better error reporting with X</flag>
</use>
<upstream>
<remote-id type="github">jstkdng/ueberzugpp</remote-id>
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.8.8.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.8.8.ebuild
new file mode 100644
index 000000000000..245e11f2f9c0
--- /dev/null
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.8.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Drop in replacement for ueberzug written in C++"
+HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
+SRC_URI="https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+# unkeyworded for now given X backend fails with ytfzf (needs investigation)
+#KEYWORDS="~amd64"
+IUSE="X opencv opengl wayland xcb-errors"
+REQUIRED_USE="xcb-errors? ( X )"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ media-gfx/chafa
+ media-libs/libsixel
+ media-libs/vips:=
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ )
+ opencv? ( media-libs/opencv:= )
+ opengl? ( media-libs/libglvnd )
+ wayland? ( dev-libs/wayland )
+ !media-gfx/ueberzug"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cli11
+ dev-cpp/ms-gsl
+ dev-cpp/nlohmann_json
+ X? ( x11-base/xorg-proto )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_OPENGL=$(usex opengl)
+ -DENABLE_TURBOBASE64=no # not packaged
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_XCB_ERRORS=$(usex xcb-errors)
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}