summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-11-22 21:58:13 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-24 15:26:08 +0200
commit0fc2f8bee8292e2e211851824a61aacee1e5dff0 (patch)
tree563142a085b7cd334aee4f7681c3883ecd2f47a2 /media-gfx
parentapp-i18n/transifex-client: remove old version (diff)
downloadgentoo-0fc2f8bee8292e2e211851824a61aacee1e5dff0.tar.gz
gentoo-0fc2f8bee8292e2e211851824a61aacee1e5dff0.tar.bz2
gentoo-0fc2f8bee8292e2e211851824a61aacee1e5dff0.zip
media-gfx/alembic: bump to 1.7.16
Remove doc USE flag, the Doxygen file has been removed upstream and building the developer documentation isn't properly implemented. Remove boost USE flag, the relevant options will get removed in the next release and aren't working in this version. Closes: https://bugs.gentoo.org/733456 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.7.16.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index c647c113758b..77d3733c65f3 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1,2 +1,3 @@
DIST alembic-1.7.11.tar.gz 826833 BLAKE2B ea2ee92cefcc92d3658b8c71351ec0f72bd1fb5d5b6c771ceebe81b1db61a280420f480cd3612f44bc134cccb388954be89baba9dc6e5973e102bc55d65cd974 SHA512 94b9c218a2fe6e2e24205aff4a2f6bab784851c2aa15592fb60ea91f0e8038b0c0656a118f3a5cba0d3de8917dd90b74d0e2d1c4ac034b9ee3f5d0741d9f6b70
DIST alembic-1.7.12.tar.gz 827983 BLAKE2B 7d508fdbfd92f213936635666a221fdad30f242a37ef8ff54a6272854565ebb890ffd11d8fe010f1558c0872fcb23080413d76380772ebf5db52033bdf0d9c85 SHA512 e05e0b24056c17f01784ced1f9606a269974de195f1aca8a6fce2123314e7ee609f70df77ac7fe18dc7f0c04fb883d38cc7de9b963caacf9586aaa24d4ac6210
+DIST alembic-1.7.16.tar.gz 855709 BLAKE2B 8009ed199b7dca190e40f56969d7c446e65bd78f58cee75dda4883ecf02b6c7ee422db76c4f523a76a4b2d42ef1547ededf5de0055cdb5d801c5cd4918a0b5f4 SHA512 bd4777dc4abf15bfb8307b00fd2d67671e89944d0dd8a74a657f4aee49e6a1cd0ab1fe5bb7f9afc63abcce2123466bb8a9a3886d41724ed2c242bc61d7d5b3a1
diff --git a/media-gfx/alembic/alembic-1.7.16.ebuild b/media-gfx/alembic/alembic-1.7.16.ebuild
new file mode 100644
index 000000000000..4167640a9e52
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.7.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake multiprocessing
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hdf5 prman test zlib"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="hdf5? ( zlib )"
+
+RDEPEND="
+ >=media-libs/openexr-2.5.0:=
+ hdf5? ( >=sci-libs/hdf5-1.10.2:=[zlib(+)] )
+ zlib? ( >=sys-libs/zlib-1.2.11-r1 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( "ACKNOWLEDGEMENTS.txt" "FEEDBACK.txt" "NEWS.txt" "README.txt" )
+
+PATCHES=( "${FILESDIR}/${PN}-1.7.11-0005-Fix-install-locations.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_SHARED_LIBS=ON
+ # C++-11 and thus {shared,unique,weak}_ptr are common nowadays, so these
+ # are no longer needed and using boost fails. Options will get removed by
+ # upstream soon
+ -DALEMBIC_LIB_USES_BOOST=OFF
+ -DALEMBIC_LIB_USES_TR1=OFF
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=$(usex prman)
+ -DUSE_PYALEMBIC=OFF
+ -DUSE_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if use prman; then
+ einfo "If you're looking for an ebuild for renderman, you may want to"
+ einfo "try the waebbl overlay: 'eselect repository enable waebbl'"
+ einfo "followed by 'emerge renderman'"
+ fi
+}