summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-12-12 11:51:39 -0600
committerBen Kohler <bkohler@gentoo.org>2023-12-12 11:51:58 -0600
commit187195844590ae0c30eda7cf6afb8857cd3d994d (patch)
tree1dac48ebddd64a909f3123fa2369f5075284a78b /media-gfx
parentmedia-video/mpv: Stabilize 0.37.0 amd64, #919769 (diff)
downloadgentoo-187195844590ae0c30eda7cf6afb8857cd3d994d.tar.gz
gentoo-187195844590ae0c30eda7cf6afb8857cd3d994d.tar.bz2
gentoo-187195844590ae0c30eda7cf6afb8857cd3d994d.zip
media-gfx/fotoxx: add 23.81
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-23.81.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index e6f4dc734fba..0e6170db98da 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -2,3 +2,4 @@ DIST fotoxx-23.70-source.tar.gz 16130595 BLAKE2B d5cd0453c7cc568ddc5a8d66d5f79f4
DIST fotoxx-23.72-source.tar.gz 16130664 BLAKE2B 913b524314ee2cf81d9f18a2a03a983585bea033e2a177e16bc213539aa9b0e76bd2b68ccee25a11529836478d0469703c614123a4e0fe627c9dde69fbee7183 SHA512 1b1f94421002da719df8d3d61e481954a017461d7f442310fcac957e71c5cf8a9bb77566f9c9451a650cb772433527a3c102c49421f291a9126b8227a34d2cb8
DIST fotoxx-23.74-source.tar.gz 16271809 BLAKE2B 88567d8da677fd95bdfbc19ebce778d7b4e64574688c4dfd56cca9d40b3bfb5005e9659801b9bf00b87e46aa10433ff32ab7aef2439b358dbdf5ffeac77be9f7 SHA512 2fe48f7a311ffa6be4be58f1769ed965a0be428956a7f0afd0ff99501c201e05877732507f27f10510f0bc29705e9184c4b92cc5eb42d31510963c70a6caf569
DIST fotoxx-23.80-source.tar.gz 16259363 BLAKE2B 15f6880c452d6b715b492c4ea46e79c43a26a7f30a3396c06e7b89edcfc8e335c75407d540e22c3a7ff9dca70c5779a544d08adebee2a75801c21e3d16e50dcb SHA512 4f0dfe47ffc811bbab7939147094b0663a1aa0fd6795d9f0f0b904d62bd4e12c8948a6cb69de33667c0f5f059e000dee62543d9f128776990b9aee772ea653e0
+DIST fotoxx-23.81-source.tar.gz 16257656 BLAKE2B 8fd21650b6c493cd77b79390dba28193272531305a21cd791578366fb464a3e34612fdd3378bfa34e50873afee65b69fd1670d4a18c0443bea388e700efaf016 SHA512 350908777b23c69b1ed630fbd3d0089748b80b3c5978b74742d10a1ad6903e362038c4ed0a10eb4916bd0f169100c001da57dfc4be0b8c9dd1c653abe459e919
diff --git a/media-gfx/fotoxx/fotoxx-23.81.ebuild b/media-gfx/fotoxx/fotoxx-23.81.ebuild
new file mode 100644
index 000000000000..6d3e66505952
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-23.81.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}-source.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-22.18-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" fotoxx.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}