summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-04-28 00:12:22 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-04-28 00:21:34 +0200
commit37e99c259eba09dad1192b22456bdc11c15f43a4 (patch)
tree4a57018b20c23c75e09ecbeaddd4d55c62da51a6 /media-gfx
parentdev-libs/json-c: Update live ebuild (diff)
downloadgentoo-37e99c259eba09dad1192b22456bdc11c15f43a4.tar.gz
gentoo-37e99c259eba09dad1192b22456bdc11c15f43a4.tar.bz2
gentoo-37e99c259eba09dad1192b22456bdc11c15f43a4.zip
media-gfx/chafa: add 1.10.2
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.10.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index 93e4bbda50aa..675fa7be7ad7 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
+DIST chafa-1.10.2.tar.xz 512468 BLAKE2B b1edec1ed687f2196a4693fa4cd08d8cabeb2b904abf387001c20ea3b5a9ca94c621bf45c467660342c3f0f049fb9706589c8b13643496b6fa2795276f032f0b SHA512 eaa0a13b1915774f25ed9fe6d7f465e695644c79e96387b71671c43876dad5f703383a876ad4ea2b5a13b2391056224cfe38cecba31264698da37af80ad540b9
DIST chafa-1.8.0.tar.xz 435712 BLAKE2B 15a6e64fff13ac32b2f828a68fb12c96856e175eae83c0396b07cbb2ce71d8c1c8eee67db00880372026fe91eaefac2b34376dee597108ffc07c706cf8c98682 SHA512 15ff08a0df82ae8517ac7744b81a39e1ae1eff8c9848128341cc25da94864e89b7101aabcff2d532bf11ea293bfc4c9e48b01f85388dafadbce2d2b2c8b7439d
diff --git a/media-gfx/chafa/chafa-1.10.2.ebuild b/media-gfx/chafa/chafa-1.10.2.ebuild
new file mode 100644
index 000000000000..9a2b941734b1
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.10.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}