summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2022-11-15 22:09:46 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-12-03 10:53:04 +0200
commit3d44e076410026b2ddf8e4ecfdec388875676332 (patch)
treef98482c9bf13722653d2205feb2f3584596098b4 /media-gfx
parentdev-ada/gprconfig_kb: add 23.0.0 (diff)
downloadgentoo-3d44e076410026b2ddf8e4ecfdec388875676332.tar.gz
gentoo-3d44e076410026b2ddf8e4ecfdec388875676332.tar.bz2
gentoo-3d44e076410026b2ddf8e4ecfdec388875676332.zip
media-gfx/hydrus: Add 505
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/hydrus-505.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index d6a1cc7db3b5..207682d17443 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -2,3 +2,4 @@ DIST hydrus-495.tar.gz 40638581 BLAKE2B 73a6b0101ec58fa32b421fdb625907e10dae006e
DIST hydrus-496.tar.gz 40644118 BLAKE2B 8acb369acb3bbe667d51eeb3de8cceef02585040ae63d50fbbff4b5e8d8f4bac29dc4cd08c9eb8f436a1fc7150bb7eb249ff3f5d13e5a4ee54a2dee877f00208 SHA512 5cc7e4f4f152790659014d675159e121aa65e275231ef43bc3bbd6efe67b458cd821d8858d94e440a1585e0040b242c5ef65368796705242e7eb8e51c62b81bf
DIST hydrus-497.tar.gz 40649206 BLAKE2B e014ff318275547ec210aa13bba1377de726b80ee1389b593ab219fc4530a44766b29111444fbc08cf50b4ca61f6129683adeb0f3835afa3cfba729e9af285b1 SHA512 39fb3e3ef3bf024913a168f616fa436013f1d2b92be102b3dfead35219420791c11b3c1846ddae577a6ee4ae3aeb9601f11d1e7ce8daac99932f14699a497242
DIST hydrus-501.tar.gz 40724774 BLAKE2B 6a93c4483b07e976fac829aee4c1f4c879f535ff0ce7e89c64b278bc3f7d77abdd9b906d48f87b175a1eccec2dcf962725abe0602fb68b009fbba9d0f3381067 SHA512 1c9275023f1d205bf916eb85566237fe8f25a446399065ebc371e1db8ca3c3e2501e8a82867e9f7711b007a74a9e88d838babca29a2556d19ffcf77b14182834
+DIST hydrus-505.tar.gz 40756022 BLAKE2B a5d9cfd5f8023a2f809c2610c48e8018ca7bb6002d1420485e463b3fe477cae07a2f4ea2cd823ff592a164d37e611938fe805d163cbf5512c636b972c1afad77 SHA512 f5c818616aa195b904d5cd65e77f29095f22fc9f435b0218110cb47e655c004c3ce3e72fc9de8ec8b1e9b508ced42b045131e0ddd6442fa43fc7d4d77877465e
diff --git a/media-gfx/hydrus/hydrus-505.ebuild b/media-gfx/hydrus/hydrus-505.ebuild
new file mode 100644
index 000000000000..86568b05547c
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-505.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+DOCS_BUILDER=mkdocs
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit python-single-r1 desktop docs optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+else
+ SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+# RDEPEND is sorted as such:
+# - No specific requirements
+# - Specific version or slot
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudscraper[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyside2[widgets,gui,${PYTHON_USEDEP}]
+ dev-python/python-mpv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ media-video/mpv[libmpv,${PYTHON_USEDEP}]
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI, not actually needed
+ rm -r static/build_files || die
+ # Python requirements files, not needed
+ rm requirements_*.txt || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+ docs_compile
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
+
+ # ${DOCS[@]} files are copied into doc
+ # ${S}/docs/ is the markdown source code for documentation
+ # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
+ rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
+ if use doc; then
+ # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
+ rm -r "${S}/_build" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html" /opt/hydrus/help
+ fi
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" || die)
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" || die)
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "automatic port forwarding support" "net-libs/miniupnpc"
+ optfeature "bandwidth charts support" "dev-python/pyside2[charts]"
+ optfeature "memory compression in the client" "dev-python/lz4"
+ optfeature "SOCKS proxy support" "dev-python/requests[socks5]" "dev-python/PySocks"
+}