summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-02-06 04:02:46 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-02-06 04:02:46 -0700
commit40fdfe14faef17082605d1c7914eccb5d6db70dc (patch)
tree7494a373b2c9fd23075ee120d9ede47a38604ab0 /media-gfx
parentmedia-libs/gexiv2: Version bump to gexiv2-0.10.8 (diff)
downloadgentoo-40fdfe14faef17082605d1c7914eccb5d6db70dc.tar.gz
gentoo-40fdfe14faef17082605d1c7914eccb5d6db70dc.tar.bz2
gentoo-40fdfe14faef17082605d1c7914eccb5d6db70dc.zip
media-gfx/shotwell: Version bump to shotwell-0.27.4
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.27.4.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index b9ded129eb6f..7c9637880199 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -9,3 +9,4 @@ DIST shotwell-0.27.0.tar.xz 5574988 BLAKE2B 30ab9ebe5fa12f8d7be3775d044b983c644b
DIST shotwell-0.27.1.tar.xz 5619824 BLAKE2B 7ba1606b1604ca156aacd71d014bdec507abd2a5447696b60ce4400cf835dd484b39e737ec7659a8744e0a5f72b9e9a561fb297db6f256db7008ca5e4b2ae0d8 SHA512 b26c25b45af305903cf0698e65d5230820dda447b70175c92a66e25148e47d620847b3fa2b3bdb8d70656186d5b30d98edf3eee4138f07db9f8260e81a95a7d6
DIST shotwell-0.27.2.tar.xz 5619692 BLAKE2B 0a532d6d2f7391f0783cb0fb91fbc15a681e87041d12355ca75581d4b7f4ebe7fe3feeaca7fc12b0fd82710bf2d906c1d3abd382b61a5dfac3041cec482edd38 SHA512 a64fec52ff1ba3bca0e4b07be557ea3b838845998ae64ac7504cd9a8c976380cf0d7aae4aaccf931f1f40b5d247e081ec98472da8e8835363779dd39d9d2f69b
DIST shotwell-0.27.3.tar.xz 5623408 BLAKE2B 582c0b4bb0636dda4aab7e0a8ca69098b1af455d8c393bd8b5d37337cc85ae38036c6020eb54eeb9fc21f2fe603631305965351bb20f8824b50b5606829a7a47 SHA512 204fd348493f25fd855955735f575da9b6de7209f27e677670b5c016cb668558a6909b71e0b1a50fcda47e29a8ac9edc40619dfff2117f637ffebfe022e12275
+DIST shotwell-0.27.4.tar.xz 5626284 BLAKE2B 2f17546c190dbd04bdf467e12a092c2558ec5bbac1e13a3054c746c391876a1ac4eeddbb4578a575cd0b73f402432ea3763fd90e214a2b0f11a6f281a77a8bac SHA512 9f67893018a750199b51ac42e357c850195a356db8fdb5b1f8836375e01291d716f82257b2b030aa41e9ead59227b442fd38239fad5b5f46bf2701ec968e383f
diff --git a/media-gfx/shotwell/shotwell-0.27.4.ebuild b/media-gfx/shotwell/shotwell-0.27.4.ebuild
new file mode 100644
index 000000000000..ed1f73414218
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.27.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/gcr-3[gtk]
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.10.4
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ >=net-libs/libsoup-2.42.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.14.0:3[X]
+ dev-libs/libgdata
+
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+ virtual/pkgconfig
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}