summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-03-01 13:28:40 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-03-01 13:28:40 +0100
commit47dac3a08c2c8b7402419875f1dab968ffe3a5b3 (patch)
tree3011fdec24998a161dfcfc4859a09b3aa834c89d /media-gfx
parentmedia-gfx/valentina-0.{5.0-r2,6.0}: removed old (diff)
downloadgentoo-47dac3a08c2c8b7402419875f1dab968ffe3a5b3.tar.gz
gentoo-47dac3a08c2c8b7402419875f1dab968ffe3a5b3.tar.bz2
gentoo-47dac3a08c2c8b7402419875f1dab968ffe3a5b3.zip
media-gfx/valentina-0.6.1: fixed bug #678670
Closes: https://bugs.gentoo.org/678670 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/valentina/files/5823.patch50
-rw-r--r--media-gfx/valentina/valentina-0.6.1.ebuild6
2 files changed, 55 insertions, 1 deletions
diff --git a/media-gfx/valentina/files/5823.patch b/media-gfx/valentina/files/5823.patch
new file mode 100644
index 000000000000..79df9a74c5a6
--- /dev/null
+++ b/media-gfx/valentina/files/5823.patch
@@ -0,0 +1,50 @@
+# HG changeset patch
+# User Roman Telezhynskyi <kroluku@gmail.com>
+# Date 1551441739 -7200
+# Fri Mar 01 14:02:19 2019 +0200
+# Branch release
+# Node ID 82e62ea2d785e093af68089e509b224f3f4f843f
+# Parent 0108ef767e2447e5b5f39378bcf245e25947a25d
+Don't use Qt OpenGL module since Q5.4.
+
+diff -r 0108ef767e24 -r 82e62ea2d785 src/app/valentina/valentina.pro
+--- a/src/app/valentina/valentina.pro Sun Feb 24 17:29:12 2019 +0200
++++ b/src/app/valentina/valentina.pro Fri Mar 01 14:02:19 2019 +0200
+@@ -297,7 +297,6 @@
+ $$[QT_INSTALL_BINS]/icuuc*.dll \ # Different name for different Qt releases
+ $$[QT_INSTALL_BINS]/Qt5Core.dll \
+ $$[QT_INSTALL_BINS]/Qt5Concurrent.dll \
+- $$[QT_INSTALL_BINS]/Qt5OpenGL.dll \
+ $$[QT_INSTALL_BINS]/Qt5Gui.dll \
+ $$[QT_INSTALL_BINS]/Qt5Network.dll \
+ $$[QT_INSTALL_BINS]/Qt5PrintSupport.dll \
+@@ -309,6 +308,11 @@
+ $$[QT_INSTALL_BINS]/libstdc++-6.dll \
+ $$[QT_INSTALL_BINS]/libwinpthread-1.dll
+
++ # Don't use Qt OpenGL module since Q5.4
++ equals(QT_MAJOR_VERSION, 5):lessThan(QT_MINOR_VERSION, 4) {
++ package.files += $$[QT_INSTALL_BINS]/Qt5OpenGL.dll
++ }
++
+ # For support Windows 7+
+ greaterThan(QT_MAJOR_VERSION, 4):greaterThan(QT_MINOR_VERSION, 6) {
+ package.files += $$[QT_INSTALL_BINS]/Qt5WinExtras.dll
+diff -r 0108ef767e24 -r 82e62ea2d785 src/libs/vwidgets/vwidgets.pro
+--- a/src/libs/vwidgets/vwidgets.pro Sun Feb 24 17:29:12 2019 +0200
++++ b/src/libs/vwidgets/vwidgets.pro Fri Mar 01 14:02:19 2019 +0200
+@@ -7,7 +7,12 @@
+ # File with common stuff for whole project
+ include(../../../common.pri)
+
+-QT += widgets printsupport opengl
++QT += widgets printsupport
++
++# Don't use Qt OpenGL module since Q5.4
++equals(QT_MAJOR_VERSION, 5):lessThan(QT_MINOR_VERSION, 4) {
++ QT += opengl
++}
+
+ # Name of the library
+ TARGET = vwidgets
+
diff --git a/media-gfx/valentina/valentina-0.6.1.ebuild b/media-gfx/valentina/valentina-0.6.1.ebuild
index c9b395040317..a59fb86953a5 100644
--- a/media-gfx/valentina/valentina-0.6.1.ebuild
+++ b/media-gfx/valentina/valentina-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,6 +38,10 @@ DEPEND="${CDEPEND}
S=${WORKDIR}/dismine-${PN}-b639b75d1688
+PATCHES=(
+ "${FILESDIR}/5823.patch"
+)
+
src_configure() {
local locales=""
local locale