summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-17 23:02:18 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-17 23:04:04 +0100
commit49f7781f888de99eddd4ef1a2b1f6af5dd4b0ace (patch)
tree6f3ce5fc186eb591b1922766b13ebf7987a29a88 /media-gfx
parentapp-metrics/process-exporter: 0.4.0-r1 bump (diff)
downloadgentoo-49f7781f888de99eddd4ef1a2b1f6af5dd4b0ace.tar.gz
gentoo-49f7781f888de99eddd4ef1a2b1f6af5dd4b0ace.tar.bz2
gentoo-49f7781f888de99eddd4ef1a2b1f6af5dd4b0ace.zip
media-gfx/xloadimage: EAPI bump
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch4
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r12.ebuild96
2 files changed, 98 insertions, 2 deletions
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch b/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch
index ffd05f62b332..da222d68c257 100644
--- a/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-libpng15.patch
@@ -1,5 +1,5 @@
---- png.c
-+++ png.c
+--- a/png.c
++++ b/png.c
@@ -75,7 +75,7 @@
{
debug(" #error ");
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r12.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r12.ebuild
new file mode 100644
index 000000000000..7e9f5a36e1e4
--- /dev/null
+++ b/media-gfx/xloadimage/xloadimage-4.1-r12.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="utility to view many different types of images under X11"
+HOMEPAGE="https://tracker.debian.org/pkg/xloadimage"
+SRC_URI="ftp://ftp.x.org/R5contrib/${P/-/.}.tar.gz
+ mirror://gentoo/${P}-gentoo-r1.diff.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="tiff jpeg png"
+
+RDEPEND="x11-libs/libX11
+ tiff? ( media-libs/tiff:0= )
+ png? ( media-libs/libpng:0= )
+ jpeg? ( virtual/jpeg:0 )"
+DEPEND="${RDEPEND}
+ !media-gfx/xli"
+
+S=${WORKDIR}/${P/-/.}
+
+src_prepare() {
+ eapply "${WORKDIR}"/${P}-gentoo-r1.diff
+ eapply "${FILESDIR}"/${P}-zio-shell-meta-char.diff
+ eapply "${FILESDIR}"/${P}-endif.patch
+
+ # Do not define errno extern, but rather include errno.h
+ # <azarah@gentoo.org> (1 Jan 2003)
+ eapply "${FILESDIR}"/${P}-include-errno_h.patch
+
+ eapply "${FILESDIR}"/xloadimage-gentoo.patch
+
+ sed -i -e "s:OPT_FLAGS=:OPT_FLAGS=$CFLAGS:" Make.conf || die
+ sed -i -e "s:^#include <varargs.h>:#include <stdarg.h>:" rlelib.c || die
+
+ # On FreeBSD systems malloc.h is a false header asking for fixes.
+ # On MacOSX it would require malloc/malloc.h
+ # On other systems it's simply unneeded
+ sed -i -e 's,<malloc.h>,<stdlib.h>,' vicar.c || die
+
+ eapply "${FILESDIR}"/${P}-unaligned-access.patch
+ eapply "${FILESDIR}"/${P}-ldflags_and_exit.patch
+
+ sed -i -e "/^DEFS = /s:/etc:${EPREFIX}/etc:" Makefile.in || die
+
+ eapply "${FILESDIR}"/${P}-libpng15.patch
+ sed -i \
+ -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
+ png.c || die
+
+ # One of the previous patches screws up a bracket...
+ eapply "${FILESDIR}"/${P}-bracket.patch
+
+ default
+
+ chmod +x configure || die
+ eautoreconf
+}
+
+src_configure() {
+ # Set TIFFHeader to TIFFHeaderCommon wrt #319383
+ has_version '>=media-libs/tiff-4.0.0_pre' && \
+ append-flags -DTIFFHeader=TIFFHeaderCommon
+
+ tc-export CC
+ econf $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff)
+}
+
+src_compile() {
+ emake SYSPATHFILE="${EPREFIX}"/etc/X11/Xloadimage
+}
+
+src_install() {
+ dobin xloadimage uufilter
+
+ dosym xloadimage /usr/bin/xsetbg
+ dosym xloadimage /usr/bin/xview
+
+ insinto /etc/X11
+ doins xloadimagerc
+
+ newman xloadimage.man xloadimage.1
+ newman uufilter.man uufilter.1
+
+ echo ".so man1/xloadimage.1" > "${T}"/xsetbg.1 || die
+ doman "${T}"/xsetbg.1
+ newman "${T}"/xsetbg.1 xview.1
+
+ dodoc README
+}