summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-11-29 19:57:30 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2020-11-30 19:37:43 +0100
commit4aeeb63fc98b2fe953777627b25e1a769110f11a (patch)
treefb73960b730ee450c6c2c9834622727db82cd8c6 /media-gfx
parentdev-python/pynest2d: added new ebuild (diff)
downloadgentoo-4aeeb63fc98b2fe953777627b25e1a769110f11a.tar.gz
gentoo-4aeeb63fc98b2fe953777627b25e1a769110f11a.tar.bz2
gentoo-4aeeb63fc98b2fe953777627b25e1a769110f11a.zip
media-gfx/cura: bump to 4.8.0
Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/cura/Manifest1
-rw-r--r--media-gfx/cura/cura-4.8.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/cura/Manifest b/media-gfx/cura/Manifest
index 8e2e7103861b..96afac35472d 100644
--- a/media-gfx/cura/Manifest
+++ b/media-gfx/cura/Manifest
@@ -1,2 +1,3 @@
DIST cura-4.6.1.tar.gz 36080329 BLAKE2B 5d86734334a2c65afd62eea6b3324b0fc543670b48f5410eac16561590706feed2320c45b22e60c9835973f965a00f222280441daf44866ffc93ebcf1295c750 SHA512 8802993a98e75428d11bfdc7721d5d48e8939ef1c783789db2941cb40b6fc8014eacbdea09c559c6d68cb1dd99def15bfb503d5c164f057a384c8a7620b15dc2
DIST cura-4.7.0.tar.gz 29712949 BLAKE2B b208a669aa38b07012099fe01ec453232c2bd3007befe649a4fd4cb0a0b12473762a5069d09218a3f2fe865141bbb8c8b7d5a26168fed02900abb20d78b0ad3f SHA512 0b3383042b9c8cf2ce27caee95c365be786c9eb40898c74ea4e0fb903241087e48a6e908d85635a9e43cf21ca3623098c6fe980d0cec3fc6a59c01c9c9cb4d9d
+DIST cura-4.8.0.tar.gz 31930258 BLAKE2B 0a10a03f5fa34ec0279b9476063f71d8ae904e05485b84fac011fa5061812cd74f4be6df7e6d93046365799fc2fb1bcf4d10d89c69d2c8455080f99c12cec153 SHA512 0a34438299908021242e47e74418e56fe61c41cff5c29df938b4705b5d23ceb6e1bd17b9eb8110f8ec75c7a08afe8928857d4f2fd5befa00c187bce717105711
diff --git a/media-gfx/cura/cura-4.8.0.ebuild b/media-gfx/cura/cura-4.8.0.ebuild
new file mode 100644
index 000000000000..cac723768e0a
--- /dev/null
+++ b/media-gfx/cura/cura-4.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..8})
+inherit cmake desktop python-single-r1 xdg
+
+MY_PN=Cura
+
+DESCRIPTION="A 3D model slicing application for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/Cura"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug +usb zeroconf"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="sys-devel/gettext"
+RDEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-libs/libcharon-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~dev-libs/libsavitar-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/pynest2d-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/uranium-${PV}[${PYTHON_SINGLE_USEDEP}]
+ ~media-gfx/curaengine-${PV}
+ ~media-gfx/fdm-materials-${PV}
+ $(python_gen_cond_dep '
+ dev-python/mypy[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_MULTI_USEDEP}]
+ sci-libs/shapely[${PYTHON_MULTI_USEDEP}]
+ usb? ( dev-python/pyserial[${PYTHON_MULTI_USEDEP}] )
+ zeroconf? ( dev-python/zeroconf[${PYTHON_MULTI_USEDEP}] )
+ ')"
+DEPEND="${RDEPEND}"
+
+DOCS=(README.md)
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ sed -i -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # trimesh not available in portage
+ local mycmakeargs=(
+ -DCURA_BUILDTYPE="ebuild"
+ -DCURA_VERSION=${PV}
+ -DCURA_NO_INSTALL_PLUGINS="AMFReader;Toolbox;TrimeshReader"
+ -DCURA_DEBUGMODE=$(usex debug)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doicon icons/*.png
+ python_fix_shebang "${D}/usr/bin/cura"
+ python_optimize "${D}${get_libdir}"
+}