summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-13 07:27:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-13 08:08:58 +0100
commit54b73e51f9f3677ed8aece323a142c5b32d525c6 (patch)
tree4cfde68aea7ac4a61914188dc2e8ce9a9bd59fa5 /media-gfx
parentdev-python/aws-sam-translator: Bump to 1.57.0 (diff)
downloadgentoo-54b73e51f9f3677ed8aece323a142c5b32d525c6.tar.gz
gentoo-54b73e51f9f3677ed8aece323a142c5b32d525c6.tar.bz2
gentoo-54b73e51f9f3677ed8aece323a142c5b32d525c6.zip
media-gfx/cairosvg: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/cairosvg/Manifest1
-rw-r--r--media-gfx/cairosvg/cairosvg-2.6.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/Manifest b/media-gfx/cairosvg/Manifest
index f4186af89ec4..c31ae596f401 100644
--- a/media-gfx/cairosvg/Manifest
+++ b/media-gfx/cairosvg/Manifest
@@ -1 +1,2 @@
DIST CairoSVG-2.5.2.tar.gz 8397659 BLAKE2B f2f45aa01015f5ccebe3dede303b6a701c0183b7b53f0d69c8756d5f0e6c0898826939f0b5bcc9e00e4185c83ff507d6fa886a020ad0b63c80a565a181807f58 SHA512 070fbb549614401a7d8290497b0eb7702330ee264c5f625cd1e7aac4aea7d71ee7d2d8899297212e1a3c11c93903b191c0c699336d9000796318b11f4e075576
+DIST CairoSVG-2.6.0.tar.gz 8398114 BLAKE2B d4aca284fe3756c40c62dfb2b29e4670c947df13dd76e5104a13cb963bbdf6aa1f7fd242748d6fd0ca524aa03578c3449fa8ea6d86b9a8ce4a64976c32e96627 SHA512 dc504233a8f3fccfc8d4082328bfc0f06a4ebe0249801f764b9aed6b3bad5f953786352930ab199b10b301d0f44a8c2ef2e79eeea198c9094e697fdaa4db48d5
diff --git a/media-gfx/cairosvg/cairosvg-2.6.0.ebuild b/media-gfx/cairosvg/cairosvg-2.6.0.ebuild
new file mode 100644
index 000000000000..5134840804bb
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-2.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="CairoSVG"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="CLI and library to export SVG to PDF, PostScript, and PNG"
+HOMEPAGE="https://cairosvg.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # this test compares output against old version; this makes little
+ # sense for us and requires both distfiles around
+ test_non_regression
+)