summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-21 04:45:47 +0000
committerSam James <sam@gentoo.org>2023-01-21 04:45:47 +0000
commit62aa7f86004ee0e299a8b773232f009e9cf88d17 (patch)
tree09979eddb6292cee1d2e73598e6290b0c6868ade /media-gfx
parentmail-client/alot: drop 0.9.1 (diff)
downloadgentoo-62aa7f86004ee0e299a8b773232f009e9cf88d17.tar.gz
gentoo-62aa7f86004ee0e299a8b773232f009e9cf88d17.tar.bz2
gentoo-62aa7f86004ee0e299a8b773232f009e9cf88d17.zip
media-gfx/scrot: add 1.8.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/scrot/Manifest1
-rw-r--r--media-gfx/scrot/scrot-1.8.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/scrot/Manifest b/media-gfx/scrot/Manifest
index e45f5018b0c7..8fcf8279c727 100644
--- a/media-gfx/scrot/Manifest
+++ b/media-gfx/scrot/Manifest
@@ -1,2 +1,3 @@
DIST scrot-1.7.tar.gz 178463 BLAKE2B 021c68c5ebd19ec08c072cff73fe1ebb7ffd179dfcde6e13656779e2ee1357cf0fdbba1d4beb2fc5dc9c8c4cd28008acaa462068eec3192cea6687ac58cd653a SHA512 3ef2b547d561a85213ef0075af3034020f00168253d3b84ef94578f0b8534f9a7389c808f8fcd0c619358a14f41601fee407d08d63c397b9892ba9fc2db23f88
+DIST scrot-1.8.1.tar.gz 178856 BLAKE2B c7c6a5169112d38f1b919c651f5b5d99abd3adcf7bdbffd971c358b3c691297ff3bca6e7d82a0fa4e63323ee50651b477f7daab2ea383eb161446b41cd75516d SHA512 a93b3ce0fc690687b50d9b06d93b30528c26f3ee0b63d16895280d0df092fea022105a6d1aa60cf58c125a5b63eda841e089123d589354901b3ed6e063b76d86
DIST scrot-1.8.tar.gz 175453 BLAKE2B 2c6cd9c6d8ea7b2dbdfa4827af52ead01327556565d957c3fc37d8511aed3247b02e61f97e1d4136fc047062fa7ff5c01f2a12b290620d2a8572b813c73413b2 SHA512 64d74da0afb4249687b757206baca704911cab34e15e56e7328d259bdb2daf984c0cd5bcd0764c7688c4340b3453cac9d6af1ce750fa65c8d7a31992dff1fcea
diff --git a/media-gfx/scrot/scrot-1.8.1.ebuild b/media-gfx/scrot/scrot-1.8.1.ebuild
new file mode 100644
index 000000000000..858ee4b9038c
--- /dev/null
+++ b/media-gfx/scrot/scrot-1.8.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+
+# imlib2[X] needed for imlib_create_image_from_drawable, bug #835582
+RDEPEND="
+ dev-libs/libbsd
+ media-libs/imlib2[X]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXinerama
+ || (
+ media-libs/imlib2[gif]
+ media-libs/imlib2[jpeg]
+ media-libs/imlib2[png]
+ media-libs/imlib2[tiff]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog README.md
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+}