summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-04-08 14:13:57 -0500
committerBen Kohler <bkohler@gentoo.org>2021-04-08 14:16:04 -0500
commit6931cc9295471db938c266bd2e0a7e858b5968f6 (patch)
tree5c3890d362fbd7faa73175b544209226bfc3331d /media-gfx
parentprofiles: Masked =dev-libs/icu-69.1 for testing (diff)
downloadgentoo-6931cc9295471db938c266bd2e0a7e858b5968f6.tar.gz
gentoo-6931cc9295471db938c266bd2e0a7e858b5968f6.tar.bz2
gentoo-6931cc9295471db938c266bd2e0a7e858b5968f6.zip
media-gfx/fotoxx: take package & bump it
Closes: https://bugs.gentoo.org/578046 Closes: https://bugs.gentoo.org/739980 Closes: https://bugs.gentoo.org/751304 Closes: https://bugs.gentoo.org/751307 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch33
-rw-r--r--media-gfx/fotoxx/fotoxx-21.40.ebuild81
-rw-r--r--media-gfx/fotoxx/metadata.xml5
4 files changed, 119 insertions, 1 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index 64a1ae728f60..a100150b5959 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -1 +1,2 @@
DIST fotoxx-15.05.tar.gz 3573278 BLAKE2B 0a7f564b2a31cf7db131d8a09a8624f087b7a5beb377949843d99d5933d5b16fb270177fe233f943af7f26753fffc6a52a5a5feea18c065f0dd99a74256a33f0 SHA512 07155e5f32c0ada33dd95de333a4a124c9fc56b3807bb2edc2b078f0eab37968f374f84701bb8ce9b200f00ed4587c83f772899ba39527378d3527050960ac0e
+DIST fotoxx-21.40.tar.gz 8583921 BLAKE2B 63e49768c6d5941fe4259f83aef4ce8d0e19498c1090e4eb5017337f184edb0c60939323cc6481efcf72d0544347e046c94e37619e1f466b6dde0ab0919c3792 SHA512 05db14fafd8187bcb1de1576ca445fe525e895089fe670a80f890b2c525f5424fabd751ea422a5cc266cc7e8175ecaf7800b97a5ad686ea3e4e482de78190f3b
diff --git a/media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch b/media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch
new file mode 100644
index 000000000000..523c640cc001
--- /dev/null
+++ b/media-gfx/fotoxx/files/fotoxx-21.40-documentation.patch
@@ -0,0 +1,33 @@
+diff -ur a/Makefile b/Makefile
+--- a/Makefile 2021-04-08 10:05:46.064519573 -0500
++++ b/Makefile 2021-04-08 10:51:26.906128397 -0500
+@@ -97,6 +97,7 @@
+
+ zfuncs.o: zfuncs.cc zfuncs.h
+ $(CXX) zfuncs.cc $(CFLAGS) \
++ -D DOCDIR=\"$(DOCDIR)\" \
+
+ # install application files in standard locations
+ PREFIX ?= /usr
+@@ -122,8 +123,7 @@
+ cp -f -R data/* $(DESTDIR)$(DATADIR)
+ cp -f -R images/* $(DESTDIR)$(IMAGEDIR)
+ # man page (21.29)
+- gzip -fk -9 man/fotoxx.man
+- mv -f man/fotoxx.man.gz $(DESTDIR)$(MANDIR)/fotoxx.1.gz
++ cp man/fotoxx.man $(DESTDIR)$(MANDIR)/fotoxx.1
+ # desktop file and icon
+ cp -f fotoxx.desktop $(DESTDIR)$(MENUDIR)
+ cp -f fotoxx.png $(DESTDIR)$(ICONDIR)
+diff -ur a/zfuncs.cc b/zfuncs.cc
+--- a/zfuncs.cc 2021-04-08 10:05:46.062519630 -0500
++++ b/zfuncs.cc 2021-04-08 11:09:07.977258807 -0500
+@@ -5615,7 +5615,7 @@
+
+ strncatv(zdatadir,199,zprefix,"/share/",zappname,"/data",null); // /prefix/share/appname/data
+ strncatv(zimagedir,199,zprefix,"/share/",zappname,"/images",null); // /prefix/share/appname/images
+- strncatv(zdocdir,199,zprefix,"/share/doc/",zappname,null); // /prefix/share/doc/appname
++ strncatv(zdocdir,199,zprefix,"/share/doc/",zappvers,null); // /prefix/share/doc/appname
+
+ ch_time = zstrdup(build_date_time,"zinitapp");
+ if (ch_time[4] == ' ') ch_time[4] = '0'; // replace month day ' d' with '0d'
diff --git a/media-gfx/fotoxx/fotoxx-21.40.ebuild b/media-gfx/fotoxx/fotoxx-21.40.ebuild
new file mode 100644
index 000000000000..3673ebe371b2
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-21.40.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx20/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ media-libs/libchamplain[gtk]
+ virtual/jpeg
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-21.40-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "additional panorama support" media-gfx/hugin
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/media-gfx/fotoxx/metadata.xml b/media-gfx/fotoxx/metadata.xml
index d1ae72d9d648..0efacfdbf8d9 100644
--- a/media-gfx/fotoxx/metadata.xml
+++ b/media-gfx/fotoxx/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
<longdescription lang="en">
Navigate a large image collection using a thumbnail browser.
Import camera RAW files and edit with 16-bit color.