summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-18 02:03:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-18 02:28:39 +0200
commit7905c64ebd0e68b9267f6965508b145591b325f5 (patch)
treedf26b9d84b7a05a46b6f6f466b2c3faed1d32b36 /media-gfx
parentkde-misc/yakuake: Drop wayland fix that broke X (diff)
downloadgentoo-7905c64ebd0e68b9267f6965508b145591b325f5.tar.gz
gentoo-7905c64ebd0e68b9267f6965508b145591b325f5.tar.bz2
gentoo-7905c64ebd0e68b9267f6965508b145591b325f5.zip
media-gfx/exiv2: Add 0.26_p20171018 snapshot from 0.26 branch
Since many commits haven't been backported yet, this is actually a tarball made of my fork, until this is decided upstream. Not pretty but better than keeping the current snapshot in tree. Gentoo-bug: 634308 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.26_p20171018.ebuild128
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch83
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch28
4 files changed, 240 insertions, 0 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index d2ca2261e265..4c27da12d82c 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1,2 +1,3 @@
DIST exiv2-0.25.tar.gz 5434325 SHA256 c80bfc778a15fdb06f71265db2c3d49d8493c382e516cb99b8c9f9cbde36efa4 SHA512 08d4e655ffdde715e0214f4bef01d55aba9b8ba517456a60e254a0f8541c20479e407545db28ca90a69dee8def6941fdd88f9a557fb382ebebe49e363aca8e8e WHIRLPOOL f9e7a6947dac5870e0574253b8c1cb1e7d31a916a9e1c4417c73168046c0b4bed90b9c77253444604163bcf6dca204dab92a52cb03bdcb0f85c807327623f8ac
DIST exiv2-0.26_p20171013.tar.gz 25801252 SHA256 137178f0dfc2734b174ba71b8b18d5852fcd5c6f7835eeb1b58f42b93eed7317 SHA512 4e8b10b8593a80615f5deb9fed3420f118338f1161b99c0b86456686fe8d511bb5df956ee25ed5edf990b34bab9efda64be5c80f6efbd78e6e497cb85e2a3ad5 WHIRLPOOL e32b9d98fa5be77bbf50bf275a95db8e9d15b0d40d762bdf512cb8d02f009fc452921df194121cd32d9780de1c83afd0da5cd75ef653a9ba1459f18884f71ffe
+DIST exiv2-0.26_p20171018.tar.gz 28370645 SHA256 7dea665ff7e58a7a858b1aa624d75f27f8b8b154cce645ef970344982c9de449 SHA512 fb4c867a5879ab46f31a1a8a7f8d24395620d6ff2a1088bc9d8d589ca110fad063e19266f4e2b75ad7bebc5b87141ed95db8e214220670a4d11092dfe654558c WHIRLPOOL b2c5060fbbb177479ffd8fbf68957d2329c0383da673b3555f602e574ee90672f55dd6105dcb25e47c9efde97dd4721d05596b22ab9f954bf9e502ffac0ee45c
diff --git a/media-gfx/exiv2/exiv2-0.26_p20171018.ebuild b/media-gfx/exiv2/exiv2-0.26_p20171018.ebuild
new file mode 100644
index 000000000000..aa1eeec5560b
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.26_p20171018.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+LINGUAS="bs de es fi fr gl ms pl pt ru sk sv ug uk vi"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ EGIT_BRANCH="0.26"
+ GIT_ECLASS=git-r3
+else
+ COMMIT=0a9962f5879335e4eb539ce419fce45a41de2770
+ SRC_URI="https://github.com/a17r/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+inherit cmake-multilib python-any-r1 vcs-snapshot
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+
+LICENSE="GPL-2"
+SLOT="0/26"
+IUSE="doc examples nls png webready xmp $(printf 'linguas_%s ' ${LINGUAS})"
+
+RDEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ webready? (
+ net-libs/libssh[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README doc/ChangeLog doc/cmd.txt )
+
+PATCHES=(
+ # TODO: Take to upstream
+ "${FILESDIR}"/${PN}-0.26-fix-docs.patch
+ "${FILESDIR}"/${PN}-0.26-tools-optional.patch
+)
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} != *9999 ]] ; then
+ if [[ -d po ]] ; then
+ pushd po > /dev/null || die
+ local lang
+ for lang in *.po; do
+ if [[ -e ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
+ case ${lang} in
+ CMakeLists.txt | \
+ ${PN}.pot) ;;
+ *) rm -r ${lang} || die ;;
+ esac
+ fi
+ done
+ popd > /dev/null || die
+ else
+ die "Failed to prepare LINGUAS - po directory moved?"
+ fi
+ fi
+
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ if use doc; then
+ einfo "Updating doxygen config"
+ doxygen &>/dev/null -u config/Doxyfile || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_ENABLE_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BUILD_PO=$(usex nls)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_SSH=$(usex webready)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_LIBXMP=NO
+ $(multilib_is_native_abi || echo -DEXIV2_ENABLE_TOOLS=NO)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && emake -j1 doc
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+ use doc && HTML_DOCS=( "${S}"/doc/html/. )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}
diff --git a/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch b/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch
new file mode 100644
index 000000000000..05ea18d6eb0c
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-fix-docs.patch
@@ -0,0 +1,83 @@
+--- a/CMakeLists.txt 2015-07-19 16:04:35.363628707 +0200
++++ b/CMakeLists.txt 2015-07-19 16:28:31.051680136 +0200
+@@ -216,9 +216,7 @@
+ ADD_SUBDIRECTORY( xmpsdk )
+ ADD_SUBDIRECTORY( src )
+
+-IF( EXIV2_ENABLE_BUILD_SAMPLES )
+- ADD_SUBDIRECTORY( samples )
+-ENDIF( EXIV2_ENABLE_BUILD_SAMPLES )
++ADD_SUBDIRECTORY( samples )
+
+ IF( EXIV2_ENABLE_BUILD_PO )
+ ADD_SUBDIRECTORY( po )
+--- a/samples/CMakeLists.txt 2015-07-19 16:04:35.360628744 +0200
++++ b/samples/CMakeLists.txt 2015-07-19 16:30:46.415987850 +0200
+@@ -21,6 +21,10 @@
+ include_directories("${CMAKE_SOURCE_DIR}/include" "${CMAKE_SOURCE_DIR}/src")
+
+-SET( SAMPLES addmoddel.cpp
++SET( SAMPLES taglist.cpp )
++
++IF( EXIV2_ENABLE_BUILD_SAMPLES )
++ SET( SAMPLES ${SAMPLES}
++ addmoddel.cpp
+ convert-test.cpp
+ easyaccess-test.cpp
+ exifcomment.cpp
+@@ -38,7 +42,6 @@
+ mmap-test.cpp
+ prevtest.cpp
+ stringto-test.cpp
+- taglist.cpp
+ tiff-test.cpp
+ werror-test.cpp
+ write-test.cpp
+@@ -47,6 +50,7 @@
+ xmpparser-test.cpp
+ xmpsample.cpp
+ )
++ENDIF()
+
+ FOREACH(entry ${SAMPLES})
+ STRING( REPLACE ".cpp" "" target ${entry})
+@@ -63,6 +67,7 @@
+ SET( MC_SRC ${MC_SRC} ../src/getopt_win32.c )
+ ENDIF( MSVC )
+
++IF( EXIV2_ENABLE_BUILD_SAMPLES )
+ SET( MC_SRC ${MC_SRC} metacopy.cpp ../src/utils.cpp )
+ ADD_EXECUTABLE( metacopy ${MC_SRC} )
+ TARGET_LINK_LIBRARIES( metacopy exiv2lib )
+@@ -79,6 +84,7 @@
+ # ******************************************************************************
+ # Man page
+ INSTALL( FILES exiv2samples.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 )
++ENDIF()
+
+ # That's all Folks!
+ ##
+--- a/doc/templates/Makefile 2015-07-19 16:50:50.589933604 +0200
++++ b/doc/templates/Makefile 2015-07-19 16:51:07.686719864 +0200
+@@ -143,7 +143,7 @@
+ xmp_mwg-rs \
+ xmp_mwg-kw
+
+-TAGLIST = ../../bin/taglist
++TAGLIST = ../../src/bin/taglist
+
+ # **********************************************************************
+ # ======================================================================
+diff --git a/doc/cmake_doc.sh b/doc/cmake_doc.sh
+index 44dd6760..5910a86d 100755
+--- a/doc/cmake_doc.sh
++++ b/doc/cmake_doc.sh
+@@ -16,7 +16,7 @@ if [ $# == 1 ]; then
+ mv src/exv_conf.h.keep src/exv_conf.h
+ fi
+ mkdir -p src/bin/
+- cp -f "${CMAKE_BINARY_DIR}/bin/taglist" src/bin/
++ cp -f "${CMAKE_BINARY_DIR}/samples/taglist" src/bin/
+ make doc
+ fi
+
diff --git a/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch b/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch
new file mode 100644
index 000000000000..36920cd0dc49
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-tools-optional.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt 2017-06-07 00:14:25.374608170 +0200
++++ b/CMakeLists.txt 2017-06-07 00:17:00.680483299 +0200
+@@ -60,6 +60,7 @@
+ OPTION( EXIV2_ENABLE_SSH "USE Libssh for SshIo" ON )
+ SET ( EXIV2_ENABLE_DYNAMIC_RUNTIME OFF )
+ ENDIF()
++OPTION( EXIV2_ENABLE_TOOLS "Build exiv2 executable" ON )
+
+ # set include path for FindXXX.cmake files
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/config/")
+--- a/src/CMakeLists.txt 2017-06-07 00:14:25.368608098 +0200
++++ b/src/CMakeLists.txt 2017-06-07 00:16:06.710831682 +0200
+@@ -317,10 +317,12 @@
+
+ # ******************************************************************************
+ # exiv2 application
+-ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} ${EXIV2_HDR} )
++IF(EXIV2_ENABLE_TOOLS)
++ ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} ${EXIV2_HDR} )
+ target_compile_definitions(exiv2 PRIVATE EXV_LOCALEDIR="${CMAKE_INSTALL_LOCALEDIR}" )
+-TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
+-INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
++ TARGET_LINK_LIBRARIES( exiv2 exiv2lib ${LIBINTL_LIBRARIES} )
++ INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
++ENDIF( EXIV2_ENABLE_TOOLS )
+
+ # ******************************************************************************
+ # connection test application