summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-04-13 13:51:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-26 17:58:04 +0200
commit7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a (patch)
tree88d12f56b231c52c0295ac5132f6f278a13041f9 /media-gfx
parentprofiles/arch/powerpc/package.use.mask: remove glibc[static-pie] mask (diff)
downloadgentoo-7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a.tar.gz
gentoo-7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a.tar.bz2
gentoo-7cd466d8c6c63fd669bc5247c3cd3e0e30659a6a.zip
media-gfx/iscan-plugin-network-nt: Version bump to 1.1.3
Closes: https://bugs.gentoo.org/711864 Signed-off-by: Marcin Deranek <marcin.deranek@slonko.net> Closes: https://github.com/gentoo/gentoo/pull/15331 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/iscan-plugin-network-nt/Manifest1
-rw-r--r--media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-network-nt/Manifest b/media-gfx/iscan-plugin-network-nt/Manifest
index 71a8787eb2c5..ddbfa87bce56 100644
--- a/media-gfx/iscan-plugin-network-nt/Manifest
+++ b/media-gfx/iscan-plugin-network-nt/Manifest
@@ -1 +1,2 @@
+DIST imagescan-bundle-centos-8-3.62.0.x64.rpm.tar.gz 11111201 BLAKE2B 51b868569fa049f8bc35a911245895c0fe0c5e0060b129c1c84a39cddd0aa4344ea024b6896dadc535438bcfc0be74337348533adf1b2be8866aad4e30bcb41a SHA512 11af49d20fc8e828c25dc6e912d1dbefebcba9835b1ebe922bc57c30dd0d13b79508a1bb01ad260c721d865fd393a41bc2bf41dc84b42efb22512a28cc9542f3
DIST iscan-bundle-2.30.4.x64.deb.tar.gz 517592 BLAKE2B f7c0638575d406ed8612f478c06fdb1331e890f932b8dc96a4dcf9fbe499683f53159103c8dfd6c1036f2bc7930bbbc4c8b18d88c460d4b48798e07f31630e0b SHA512 6d967f5d2d554478df49c784d0ee785a9e1fc4f4b6ea4dc320270a50eca35cc3d533b918a1bda33cf3b0e9b783380e7828b77543730079b2e2f40ad9578db79d
diff --git a/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild b/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
new file mode 100644
index 000000000000..b1b7f05ba96d
--- /dev/null
+++ b/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info rpm
+
+DESCRIPTION="Network scanning plugin for EPSON scanners (nonfree)"
+
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+ISCAN_VERSION="3.62.0"
+
+SRC_URI="https://download2.ebz.epson.net/imagescanv3/centos/latest1/rpm/x64/imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/iscan"
+RESTRICT="bindist mirror strip"
+# https://bugs.gentoo.org/364129#c15
+CONFIG_CHECK="~SYN_COOKIES"
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack ./imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm/plugins/imagescan-plugin-networkscan-${PV}-1epson4centos8.x86_64.rpm
+}
+
+src_install() {
+ exeinto /usr/libexec/utsushi
+ doexe usr/libexec/utsushi/networkscan
+
+ gunzip usr/share/doc/imagescan-plugin-networkscan/*.gz
+ dodoc usr/share/doc/imagescan-plugin-networkscan/*
+}