summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-02-25 16:41:50 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:24 +0100
commit7d68213be176c432b7be47bc70bbf9020356bdfd (patch)
tree86ca59ab36342a034c135d318c125a248faa4cc4 /media-gfx
parentsys-apps/stroke: EAPI8, fix LICENSE, fix bug #725814 (diff)
downloadgentoo-7d68213be176c432b7be47bc70bbf9020356bdfd.tar.gz
gentoo-7d68213be176c432b7be47bc70bbf9020356bdfd.tar.bz2
gentoo-7d68213be176c432b7be47bc70bbf9020356bdfd.zip
media-gfx/darktable: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch26
-rw-r--r--media-gfx/darktable/files/darktable-4.2.1-exiv2-0.28.patch215
2 files changed, 0 insertions, 241 deletions
diff --git a/media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch b/media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch
deleted file mode 100644
index 8ad4f0e9329f..000000000000
--- a/media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Darktable and RawSpeed upstream support two build modes: if BINARY_PACKAGE_BUILD==1
-they pass -mtune=generic to the compiler, otherwise they use -march=native.
-In either case, these options override externally set CFLAGS.
-
-Disable this behaviour so that the users' settings provided to the ebuild by Portage
-are respected.
-
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -521,7 +521,7 @@
- set(DT_REQ_INSTRUCTIONS "-msse2")
- endif()
-
-- include(march-mtune)
-+ set(MARCH "")
-
- #if(NOT BUILD_SSE2_CODEPATHS)
- # set(MARCH "${MARCH} -mno-sse2 -D__DISABLE_SSE2__ -U__SSE2__ -D__DISABLE_SSE__ -U__SSE__")
---- a/src/external/rawspeed/cmake/compiler-flags.cmake
-+++ b/src/external/rawspeed/cmake/compiler-flags.cmake
-@@ -1,5 +1,4 @@
- include(CheckCXXCompilerFlag)
--include(CpuMarch)
- include(CheckCXXCompilerFlagAndEnableIt)
-
- # yes, need to keep both the CMAKE_CXX_FLAGS and CMAKE_CXX_STANDARD.
diff --git a/media-gfx/darktable/files/darktable-4.2.1-exiv2-0.28.patch b/media-gfx/darktable/files/darktable-4.2.1-exiv2-0.28.patch
deleted file mode 100644
index 1be8577ae369..000000000000
--- a/media-gfx/darktable/files/darktable-4.2.1-exiv2-0.28.patch
+++ /dev/null
@@ -1,215 +0,0 @@
-diff --git a/src/common/exif.cc b/src/common/exif.cc
-index 484ebf2207..91ea8e64d0 100644
---- a/src/common/exif.cc
-+++ b/src/common/exif.cc
-@@ -80,6 +80,11 @@ extern "C" {
-
- #define DT_XMP_EXIF_VERSION 5
-
-+#if EXIV2_TEST_VERSION(0,28,0)
-+#define AnyError Error
-+#define toLong toInt64
-+#endif
-+
- // persistent list of exiv2 tags. set up in dt_init()
- static GList *exiv2_taglist = NULL;
-
-@@ -2658,39 +2663,39 @@ static GList *read_history_v2(Exiv2::XmpData &xmpData, const char *filename)
- if(g_str_has_prefix(key_iter, "darktable:operation"))
- {
- current_entry->have_operation = TRUE;
-- current_entry->operation = g_strdup(history->value().toString().c_str());
-+ current_entry->operation = g_strdup(history->toString().c_str());
- }
- else if(g_str_has_prefix(key_iter, "darktable:num"))
- {
-- current_entry->num = history->value().toLong();
-+ current_entry->num = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:enabled"))
- {
-- current_entry->enabled = history->value().toLong() == 1;
-+ current_entry->enabled = history->toLong() == 1;
- }
- else if(g_str_has_prefix(key_iter, "darktable:modversion"))
- {
- current_entry->have_modversion = TRUE;
-- current_entry->modversion = history->value().toLong();
-+ current_entry->modversion = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:params"))
- {
- current_entry->have_params = TRUE;
-- current_entry->params = dt_exif_xmp_decode(history->value().toString().c_str(), history->value().size(),
-+ current_entry->params = dt_exif_xmp_decode(history->toString().c_str(), history->size(),
- &current_entry->params_len);
- }
- else if(g_str_has_prefix(key_iter, "darktable:multi_name"))
- {
-- current_entry->multi_name = g_strdup(history->value().toString().c_str());
-+ current_entry->multi_name = g_strdup(history->toString().c_str());
- }
- else if(g_str_has_prefix(key_iter, "darktable:multi_priority"))
- {
-- current_entry->multi_priority = history->value().toLong();
-+ current_entry->multi_priority = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:iop_order"))
- {
- // we ensure reading the iop_order as a high precision float
-- string str = g_strdup(history->value().toString().c_str());
-+ string str = g_strdup(history->toString().c_str());
- static const std::locale& c_locale = std::locale("C");
- std::istringstream istring(str);
- istring.imbue(c_locale);
-@@ -2698,12 +2703,12 @@ static GList *read_history_v2(Exiv2::XmpData &xmpData, const char *filename)
- }
- else if(g_str_has_prefix(key_iter, "darktable:blendop_version"))
- {
-- current_entry->blendop_version = history->value().toLong();
-+ current_entry->blendop_version = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:blendop_params"))
- {
-- current_entry->blendop_params = dt_exif_xmp_decode(history->value().toString().c_str(),
-- history->value().size(),
-+ current_entry->blendop_params = dt_exif_xmp_decode(history->toString().c_str(),
-+ history->size(),
- &current_entry->blendop_params_len);
- }
- }
-@@ -2858,35 +2863,35 @@ static GList *read_masks_v3(Exiv2::XmpData &xmpData, const char *filename, const
- // go on reading things into current_entry
- if(g_str_has_prefix(key_iter, "darktable:mask_num"))
- {
-- current_entry->mask_num = history->value().toLong();
-+ current_entry->mask_num = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_id"))
- {
-- current_entry->mask_id = history->value().toLong();
-+ current_entry->mask_id = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_type"))
- {
-- current_entry->mask_type = history->value().toLong();
-+ current_entry->mask_type = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_name"))
- {
-- current_entry->mask_name = g_strdup(history->value().toString().c_str());
-+ current_entry->mask_name = g_strdup(history->toString().c_str());
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_version"))
- {
-- current_entry->mask_version = history->value().toLong();
-+ current_entry->mask_version = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_points"))
- {
-- current_entry->mask_points = dt_exif_xmp_decode(history->value().toString().c_str(), history->value().size(), &current_entry->mask_points_len);
-+ current_entry->mask_points = dt_exif_xmp_decode(history->toString().c_str(), history->size(), &current_entry->mask_points_len);
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_nb"))
- {
-- current_entry->mask_nb = history->value().toLong();
-+ current_entry->mask_nb = history->toLong();
- }
- else if(g_str_has_prefix(key_iter, "darktable:mask_src"))
- {
-- current_entry->mask_src = dt_exif_xmp_decode(history->value().toString().c_str(), history->value().size(), &current_entry->mask_src_len);
-+ current_entry->mask_src = dt_exif_xmp_decode(history->toString().c_str(), history->size(), &current_entry->mask_src_len);
- }
-
- }
-@@ -4060,7 +4065,11 @@ char *dt_exif_xmp_read_string(const int imgid)
- std::string xmpPacket;
-
- Exiv2::DataBuf buf = Exiv2::readFile(WIDEN(input_filename));
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ xmpPacket.assign(buf.c_str(), buf.size());
-+#else
- xmpPacket.assign(reinterpret_cast<char *>(buf.pData_), buf.size_);
-+#endif
- Exiv2::XmpParser::decode(xmpData, xmpPacket);
- // because XmpSeq or XmpBag are added to the list, we first have
- // to remove these so that we don't end up with a string of duplicates
-@@ -4076,7 +4085,11 @@ char *dt_exif_xmp_read_string(const int imgid)
- std::string xmpPacket;
-
- Exiv2::DataBuf buf = Exiv2::readFile(WIDEN(input_filename));
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ xmpPacket.assign(buf.c_str(), buf.size());
-+#else
- xmpPacket.assign(reinterpret_cast<char *>(buf.pData_), buf.size_);
-+#endif
- Exiv2::XmpParser::decode(sidecarXmpData, xmpPacket);
-
- for(Exiv2::XmpData::const_iterator it = sidecarXmpData.begin(); it != sidecarXmpData.end(); ++it)
-@@ -4204,7 +4217,11 @@ int dt_exif_xmp_attach_export(const int imgid, const char *filename, void *metad
- std::string xmpPacket;
-
- Exiv2::DataBuf buf = Exiv2::readFile(WIDEN(input_filename));
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ xmpPacket.assign(buf.c_str(), buf.size());
-+#else
- xmpPacket.assign(reinterpret_cast<char *>(buf.pData_), buf.size_);
-+#endif
- Exiv2::XmpParser::decode(sidecarXmpData, xmpPacket);
-
- for(Exiv2::XmpData::const_iterator it = sidecarXmpData.begin(); it != sidecarXmpData.end(); ++it)
-@@ -4371,7 +4388,7 @@ int dt_exif_xmp_attach_export(const int imgid, const char *filename, void *metad
- catch(Exiv2::AnyError &e)
- {
- #if EXIV2_TEST_VERSION(0,27,0)
-- if(e.code() == Exiv2::kerTooLargeJpegSegment)
-+ if(e.code() == Exiv2::ErrorCode::kerTooLargeJpegSegment)
- #else
- if(e.code() == 37)
- #endif
-@@ -4437,7 +4454,11 @@ int dt_exif_xmp_write(const int imgid, const char *filename)
- }
-
- Exiv2::DataBuf buf = Exiv2::readFile(WIDEN(filename));
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ xmpPacket.assign(buf.c_str(), buf.size());
-+#else
- xmpPacket.assign(reinterpret_cast<char *>(buf.pData_), buf.size_);
-+#endif
- Exiv2::XmpParser::decode(xmpData, xmpPacket);
- // because XmpSeq or XmpBag are added to the list, we first have
- // to remove these so that we don't end up with a string of duplicates
-diff --git a/tools/basecurve/exif-wrapper.cpp b/tools/basecurve/exif-wrapper.cpp
-index f4d4d46e12..41bb021012 100644
---- a/tools/basecurve/exif-wrapper.cpp
-+++ b/tools/basecurve/exif-wrapper.cpp
-@@ -19,6 +19,7 @@
- #include <exiv2/exif.hpp>
- #include <exiv2/error.hpp>
- #include <exiv2/image.hpp>
-+#include <exiv2/version.hpp>
-
- #include <cstdio>
- #include <cassert>
-@@ -36,13 +37,21 @@ exif_get_ascii_datafield(
-
- try
- {
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ Exiv2::Image::UniquePtr image = Exiv2::ImageFactory::open(filename);
-+#else
- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(filename);
-+#endif
- assert(image.get() != 0);
- image->readMetadata();
-
- Exiv2::ExifData &exifData = image->exifData();
-
-+#if EXIV2_TEST_VERSION(0,28,0)
-+ Exiv2::Value::UniquePtr val = exifData[key].getValue();
-+#else
- Exiv2::Value::AutoPtr val = exifData[key].getValue();
-+#endif
-
- if (val->typeId() != Exiv2::asciiString)
- {