summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-15 11:07:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-15 11:07:56 +0100
commit7f0aaca331451b324b62d43195a6fa0778f1c022 (patch)
tree4994145c6047117059a71bb5824ae00df632ef08 /media-gfx
parentsci-mathematics/ginac: drop 1.8.6 (diff)
downloadgentoo-7f0aaca331451b324b62d43195a6fa0778f1c022.tar.gz
gentoo-7f0aaca331451b324b62d43195a6fa0778f1c022.tar.bz2
gentoo-7f0aaca331451b324b62d43195a6fa0778f1c022.zip
media-gfx/enblend: drop 4.2.0_p20161007-r5
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/enblend/enblend-4.2.0_p20161007-r5.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/media-gfx/enblend/enblend-4.2.0_p20161007-r5.ebuild b/media-gfx/enblend/enblend-4.2.0_p20161007-r5.ebuild
deleted file mode 100644
index 582627f70f78..000000000000
--- a/media-gfx/enblend/enblend-4.2.0_p20161007-r5.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Image Blending with Multiresolution Splines"
-HOMEPAGE="http://enblend.sourceforge.net/"
-SRC_URI="https://dev.gentoo.org/~soap/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2+ FDL-1.2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="cpu_flags_x86_sse2 debug doc openmp tcmalloc"
-
-REQUIRED_USE="tcmalloc? ( !debug )"
-
-BDEPEND="
- sys-apps/help2man
- virtual/pkgconfig
- doc? (
- app-text/ghostscript-gpl
- app-text/texlive
- dev-lang/perl
- dev-perl/Readonly
- dev-tex/hevea
- gnome-base/librsvg
- media-gfx/graphviz
- media-gfx/transfig
- sci-visualization/gnuplot[cairo,gd]
- virtual/imagemagick-tools[tiff]
- )
-"
-RDEPEND="
- media-libs/lcms:2
- media-libs/tiff:=
- media-libs/vigra[openexr]
- sci-libs/gsl:=
- debug? ( dev-libs/dmalloc[threads] )
- tcmalloc? ( dev-util/google-perftools )
-"
-DEPEND="${RDEPEND}
- dev-libs/boost
- media-libs/libpng:0
- media-libs/libjpeg-turbo:=
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.2-doc-install-dir-fix.patch
- "${FILESDIR}"/${P}-cmake.patch
- "${FILESDIR}"/${P}-gcc-10.patch
- "${FILESDIR}"/${P}-doc-scaleable-fonts.patch
-)
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i -e "s:share/doc/enblend:share/doc/${PF}:" doc/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_SSE2=$(usex cpu_flags_x86_sse2)
- -DENABLE_DMALLOC=$(usex debug)
- -DDOC=$(usex doc)
- -DENABLE_OPENMP=$(usex openmp)
- -DENABLE_TCMALLOC=$(usex tcmalloc)
- )
- if use doc; then
- mycmakeargs+=(
- -DINSTALL_HTML_DOC=ON
- -DINSTALL_PDF_DOC=ON
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- # To allow icon resizing with renderers (no way to disable)
- addpredict /dev/dri
-
- # To compile fonts in the temp directory
- export VARTEXFONTS="${T}/fonts"
-
- # forcing -j1 as every parallel compilation process needs about 1 GB RAM.
- cmake_src_compile -j1
-}