summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 16:07:06 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 16:07:06 +0100
commit972df64821a507399db6f4ed258b4f512fb78151 (patch)
treea056aea4ab2d2c5f93979ae05443a095106bcebd /media-gfx
parentmedia-gfx/aview: Port to EAPI 7 (diff)
downloadgentoo-972df64821a507399db6f4ed258b4f512fb78151.tar.gz
gentoo-972df64821a507399db6f4ed258b4f512fb78151.tar.bz2
gentoo-972df64821a507399db6f4ed258b4f512fb78151.zip
media-gfx/crwinfo: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/crwinfo/crwinfo-0.2.ebuild14
-rw-r--r--media-gfx/crwinfo/files/crwinfo-0.2.patch9
2 files changed, 13 insertions, 10 deletions
diff --git a/media-gfx/crwinfo/crwinfo-0.2.ebuild b/media-gfx/crwinfo/crwinfo-0.2.ebuild
index 09e639edc0a7..6f3b79d7548b 100644
--- a/media-gfx/crwinfo/crwinfo-0.2.ebuild
+++ b/media-gfx/crwinfo/crwinfo-0.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Canon raw image (CRW) information and thumbnail extractor"
HOMEPAGE="http://freshmeat.net/projects/crwinfo/"
@@ -12,16 +12,14 @@ SRC_URI="http://neuemuenze.heim1.tu-clausthal.de/~sven/crwinfo/CRWInfo-${PV}.tar
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
S="${WORKDIR}/CRWInfo-${PV}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}.patch
- sed \
- -e '/gcc/s:^.*$:\t$(CC) $(CFLAGS) -Wall -c crwinfo.c\n\t$(CC) $(LDFLAGS) -o crwinfo crwinfo.o:g' \
- -i Makefile || die
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+src_compile() {
tc-export CC
+ emake crwinfo
}
src_install() {
diff --git a/media-gfx/crwinfo/files/crwinfo-0.2.patch b/media-gfx/crwinfo/files/crwinfo-0.2.patch
index 18170b10d71e..1753ed0bdf3e 100644
--- a/media-gfx/crwinfo/files/crwinfo-0.2.patch
+++ b/media-gfx/crwinfo/files/crwinfo-0.2.patch
@@ -1,5 +1,5 @@
---- crwinfo.c.orig 2002-07-30 11:17:03.000000000 -0600
-+++ crwinfo.c 2005-01-21 15:24:54.256888228 -0700
+--- a/crwinfo.c
++++ b/crwinfo.c
@@ -95,10 +95,10 @@
fprintf( stderr, "-m show misc. information (whitepoint, AF mode etc)\n" );
fprintf( stderr, "-f show flash information (flash mode etc)\n" );
@@ -15,3 +15,8 @@
fprintf( stderr, "-x show experimental information (don't rely on it)\n" );
exit(0);
}
+--- a/Makefile
++++ b/Makefile
+@@ -1,2 +0,0 @@
+-all:
+- gcc -o crwinfo -W -Wall -g crwinfo.c