summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-11-16 07:28:03 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-11-25 10:23:14 +0200
commit9bd7ebe9394df46e8116c3f2e2626c75410bf805 (patch)
tree87ff99f36d3889113c90fe275a666b40ae0999d4 /media-gfx
parentsci-libs/libgeotiff: Stabilize 1.7.1-r1 arm64, #882919 (diff)
downloadgentoo-9bd7ebe9394df46e8116c3f2e2626c75410bf805.tar.gz
gentoo-9bd7ebe9394df46e8116c3f2e2626c75410bf805.tar.bz2
gentoo-9bd7ebe9394df46e8116c3f2e2626c75410bf805.zip
media-gfx/alembic: add 1.8.4
Closes: https://bugs.gentoo.org/881177 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/28336 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.8.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 487eddd79e33..0e6d302f6ce2 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.8.3.tar.gz 862221 BLAKE2B 81639b0968dbcaac0096eac83385b7d6b1dc27b4b1652ede8cf6b6cf3aa3eea3c6f5e53f033708b61f79d99ebfaa766a9cac3345a043d6cc0ba6d6c29dcb9ed0 SHA512 0049c72d93e66e12d704d27e7ba36cd9c718667f2ce4f7baa1bee1613ed88ba53abea98f457e14f7f2144cb353810a4108d26c7dd1a1543ec2af576272f19036
+DIST alembic-1.8.4.tar.gz 867788 BLAKE2B b7bc5ebcaebc5905a9a2e45be21170a72923fd6af6d9f97b81bdc7e8b80bb037ed3f667ea15a5b96194b33687010fda455e4df8355f92fc29aa000beae32cae8 SHA512 2473f4b9afe3fddbd2d0477bdc85d93697e413410253a7f7f0f030fba919dfb63dabd2d2d13829f59f3f901643ab842d230a9f08fb667e2c16cef0e751a8a687
diff --git a/media-gfx/alembic/alembic-1.8.4.ebuild b/media-gfx/alembic/alembic-1.8.4.ebuild
new file mode 100644
index 000000000000..3bf6ec05cfba
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.8.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py311 needs imath-3.1.6+, see PR #28265
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="examples hdf5 python test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/imath:=
+ python? ( dev-libs/imath:=[python,${PYTHON_SINGLE_USEDEP}] )
+ hdf5? (
+ >=sci-libs/hdf5-1.10.2:=[zlib(+)]
+ >=sys-libs/zlib-1.2.11-r1
+ )
+ python? ( $(python_gen_cond_dep 'dev-libs/boost[python,${PYTHON_USEDEP}]') )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.0-0001-set-correct-libdir.patch )
+
+DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_BUILD_LIBS=ON
+ -DALEMBIC_DEBUG_WARNINGS_AS_ERRORS=OFF
+ -DALEMBIC_SHARED_LIBS=ON
+ # currently does nothing but require doxygen
+ -DDOCS_PATH=OFF
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=OFF
+ -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_TESTS=$(usex test)
+ )
+
+ use python && mycmakeargs+=( -DPython3_EXECUTABLE=${PYTHON} )
+
+ cmake_src_configure
+}
+
+# some tests may fail if run in parallel mode
+# see https://github.com/alembic/alembic/issues/401
+src_test() {
+ cmake_src_test -j1
+}