summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-19 21:18:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-19 21:19:01 +0100
commit9e4e8555087b7cb392059bf12c79ac8549f383c4 (patch)
treecca0c55b23767f06eeb1adb82b5860e2b116624c /media-gfx
parentmedia-gfx/exiv2: drop 0.27.7, 0.28.1-r1 (diff)
downloadgentoo-9e4e8555087b7cb392059bf12c79ac8549f383c4.tar.gz
gentoo-9e4e8555087b7cb392059bf12c79ac8549f383c4.tar.bz2
gentoo-9e4e8555087b7cb392059bf12c79ac8549f383c4.zip
media-gfx/exiv2: add 0.28.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.28.2.ebuild131
-rw-r--r--media-gfx/exiv2/files/exiv2-0.28.2-errors-localisation.patch23
3 files changed, 155 insertions, 0 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index e718292d55e6..0d500799da92 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1 +1,2 @@
DIST exiv2-0.28.1.tar.gz 45225200 BLAKE2B a26f8e54cf6284c56ff429c13d5a8985dc6181a36b4c13ea6f2e59bc00016a2a8d915ddbc0cedb441b8283e30f18312a500900ffd89ca984006ac84807a03852 SHA512 7b872a3c0cbe343014b1ca4618cecaf6ee8d78dec7ef83accfce95cb8eadc6b52116977a41e1f1be5c6149a47bdd9457fadc08d73708aa2a6ab69795fd3de23b
+DIST exiv2-0.28.2.tar.gz 45224206 BLAKE2B 9d1d05c99804032dfb9b740e543d1e3cceae011b17853c8565ccad87e726ce1d0f410c13bf4fa8839bc8e0fecdf170a3acac568f14aad4628b3b844f6c21dd7e SHA512 197cc607c0271b5731714713283756250031cef81ba7ed5d9c3e222b4c2397966cc2bbdbceaae706598329dde6f8a9729597d0ae4c36ac264c76546942e4e37b
diff --git a/media-gfx/exiv2/exiv2-0.28.2.ebuild b/media-gfx/exiv2/exiv2-0.28.2.ebuild
new file mode 100644
index 000000000000..c7e62ae426fc
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.28.2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://exiv2.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Exiv2/exiv2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+# Upstream hope to have stable ABI in 1.0. Until then, go off ${PV}.
+# We may be able to change it to $(ver_cut 1-2) once e.g.
+# https://github.com/Exiv2/exiv2/pull/917 is merged.
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+bmff doc examples nls +png test webready +xmp"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/inih[${MULTILIB_USEDEP}]
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? (
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+DEPEND="${DEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-text/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ test? ( ${PYTHON_DEPS} )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+PATCHES=( "${FILESDIR}/${P}-errors-localisation.patch" )
+
+pkg_setup() {
+ if use doc || use test ; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ cmake_src_prepare
+
+ sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BROTLI=OFF
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_INIH=ON # must be enabled (bug #921937)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_BMFF=$(usex bmff)
+
+ # We let users control this.
+ -DBUILD_WITH_CCACHE=OFF
+ # Our toolchain sets this by default.
+ -DBUILD_WITH_STACK_PROTECTOR=OFF
+
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_UNIT_TESTS=$(usex test))
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ if use doc || use test ; then
+ mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && eninja doc
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ cd "${BUILD_DIR}"/bin || die
+ ./unit_tests || die "Failed to run tests"
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}
diff --git a/media-gfx/exiv2/files/exiv2-0.28.2-errors-localisation.patch b/media-gfx/exiv2/files/exiv2-0.28.2-errors-localisation.patch
new file mode 100644
index 000000000000..7799232d74a8
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.28.2-errors-localisation.patch
@@ -0,0 +1,23 @@
+From a3985001b13132ce4841bf1170626f7ef8f9dae7 Mon Sep 17 00:00:00 2001
+From: Jim Easterbrook <jim@jim-easterbrook.me.uk>
+Date: Thu, 15 Feb 2024 16:41:35 +0000
+Subject: [PATCH] Restore localisation of error messages/exceptions
+
+Signed-off-by: Jim Easterbrook <jim@jim-easterbrook.me.uk>
+---
+ src/error.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/error.cpp b/src/error.cpp
+index c4ce1f2e01..135f4730d8 100644
+--- a/src/error.cpp
++++ b/src/error.cpp
+@@ -163,7 +163,7 @@ const char* Error::what() const noexcept {
+ }
+
+ void Error::setMsg(int count) {
+- std::string msg{errList.at(static_cast<size_t>(code_))};
++ std::string msg{_(errList.at(static_cast<size_t>(code_)))};
+ auto pos = msg.find("%0");
+ if (pos != std::string::npos) {
+ msg.replace(pos, 2, std::to_string(static_cast<int>(code_)));