summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2023-11-28 23:07:23 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-03-12 11:54:11 +0200
commita70cc5184b5fb5f5708c9fedc462e3cb8f90c505 (patch)
treebc776bddf3f870857743face34d21a8e50fb6514 /media-gfx
parentmedia-gfx/hydrus: Drop 534 (diff)
downloadgentoo-a70cc5184b5fb5f5708c9fedc462e3cb8f90c505.tar.gz
gentoo-a70cc5184b5fb5f5708c9fedc462e3cb8f90c505.tar.bz2
gentoo-a70cc5184b5fb5f5708c9fedc462e3cb8f90c505.zip
media-gfx/hydrus: Add 553
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hydrus/Manifest2
-rw-r--r--media-gfx/hydrus/hydrus-553.ebuild153
2 files changed, 155 insertions, 0 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index e44d3683a5a0..b4c0dab942bf 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1 +1,3 @@
+DIST 3500-mpeg-error.patch 1630 BLAKE2B d0d5cc7ee34d7615361890f9e51630ee7a4b93b6f477f991113d2ae8e35f4a83a7ce5075da10157f83f2e182fb83efb8d548d79b0724aa6942238e31fe56d6e8 SHA512 4e929b09ed8a52c31063f5a34ea84ae81ad8bb75c9e1ea5ab7ce8a99b993e562d3ff35f69ea50720b03366114d1ba2954c3a0a8de70805364a50b06fdd62af8c
DIST hydrus-538.tar.gz 41659526 BLAKE2B 4e6f4058fc8eefb154ec08667d9d586e48df688de2e887bae05cc381dc15c56ba2da4a97d1194bac2547af24a690e8d6962f05792babb68a9f0d5fb9ca23047e SHA512 da7bebf294356455597d8397391edcd3c7af032ef2d494ed2e91277c58bd29516068ba9ed99fa5df8d7bbfc47beb3488b3d73a0d99cb946d57546b095b6d6cd6
+DIST hydrus-553.tar.gz 45244801 BLAKE2B 4d4133a134d6ea07a4ee4a611a25946d8b16081be827618c6bbd93cb660e34fae60c88881ef85b3ce7f8d48ad251609a9ce895c089baba17018f001f427c99d5 SHA512 ae50e056e9c7faf43da98ceff163c246cc09a33b5d659fb1963b693e00c566b35b39cfe15dcd0e4e0c2e998dc5dc4e198ffe1549696b7c9b97ab639934924d2f
diff --git a/media-gfx/hydrus/hydrus-553.ebuild b/media-gfx/hydrus/hydrus-553.ebuild
new file mode 100644
index 000000000000..aae4cae9e374
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-553.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+DOCS_BUILDER=mkdocs
+DOCS_DEPEND="dev-python/mkdocs-material dev-python/regex"
+
+inherit python-single-r1 desktop docs optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+else
+ SRC_URI="
+ https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vaartis/hydrus/commit/5d2505a1eb4721f7750861f7622c46adec31db8b.diff -> 3500-mpeg-error.patch
+"
+
+ KEYWORDS="~amd64"
+fi
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+# RDEPEND is sorted as such:
+# Python libraries with no specific requirements
+# Python libraries with specific version, slot, or use requirements
+# Non-python dependencies
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudscraper[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-mpv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/service-identity[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+
+ dev-python/QtPy[widgets,gui,svg,multimedia,${PYTHON_USEDEP}]
+ || ( dev-python/QtPy[pyside2] dev-python/QtPy[pyside6] )
+
+ media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+ "${DISTDIR}/3500-mpeg-error.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Python requirements file, not needed
+ rm requirements.txt || die
+ # Remove unneeded additional scripts
+ rm *.command *.sh *.bat || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+ docs_compile
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/hydrus_test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm hydrus_test.py hydrus/hydrus_test_boot.py || die
+ rm -r hydrus/test/ static/testing/ || die
+ # Build files used for CI and development, not actually needed. Has to be deleted after src_compile.
+ # because it contains documentation
+ rm -r static/build_files static/requirements || die
+
+ # ${DOCS[@]} files are copied into doc
+ # ${S}/docs/ is the markdown source code for documentation
+ # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
+ rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
+ if use doc; then
+ # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
+ rm -r "${S}/_build" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html" /opt/hydrus/help
+ fi
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" || die)
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" || die)
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "automatic port forwarding support" "net-libs/miniupnpc"
+ optfeature "memory compression in the client" "dev-python/lz4"
+ optfeature "SOCKS proxy support" "dev-python/requests[socks5]" "dev-python/PySocks"
+ optfeature "bandwidth charts support" "dev-python/pyside2[charts]" "dev-python/pyside6[charts]"
+}