summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-08-28 18:19:24 +0300
committerSam James <sam@gentoo.org>2021-08-28 17:50:24 +0100
commitafc14c09b6f873082a9fb72c676d92827411a6b7 (patch)
tree7a416cc4999f8e7f6c50afe534b822e41a328eba /media-gfx
parentmedia-gfx/hydrus: Drop 447 (diff)
downloadgentoo-afc14c09b6f873082a9fb72c676d92827411a6b7.tar.gz
gentoo-afc14c09b6f873082a9fb72c676d92827411a6b7.tar.bz2
gentoo-afc14c09b6f873082a9fb72c676d92827411a6b7.zip
media-gfx/hydrus: Add 452
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Closes: https://github.com/gentoo/gentoo/pull/22142 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/hydrus-452.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index 54e66ea38163..61118130f142 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1,3 +1,4 @@
DIST hydrus-448.tar.gz 38851906 BLAKE2B 2b60174ffea3dd0c3816afef12378546582dfc39f80406534fa8b868c33052dc8497fa750ed724388467fd9ed4f1a7245b7ef91745750b9ede834a94e2da9638 SHA512 a16879dfd3417a784ca900b6cdab5fb4079d8ca4179224ac69e37321e165f35483d476b40994f2445c846998b2f154498da3cbd9c695a9d96b71f187e788b7b3
DIST hydrus-450.tar.gz 38861101 BLAKE2B fd7993a4d9f82da43b4a6ae83426452b8bb79bcc32a9038ff129c4673c618b89db4a79301d06d2cc7c244053904cd201e88d496e05f7fcf723874e929275af08 SHA512 1c55a173863f7fee90288e1bc85203d12aaf812ab4afb506bc72c24d9b25dfea8ef1785043d801c2bea6302c65d4342ec2f58f47927fbb2d274ba433d29d8230
DIST hydrus-451.tar.gz 38867387 BLAKE2B 80a7139ebcc1447b8eb35754dd65b54127a2b5107bbb8bdb371476f9db984bcd5b9ff388ec726ed5fca31acf69a180c288e1c6cdfabfdef1c72772402d22f3f0 SHA512 482095c03d44979e99e4f3027fa9b6f5c9b90692e29a28246f1e0b4c6fa20c6ed3b1d9e421d3b9bb723a094c1f0aea6aa7468247e23b54570ee99e26dce41654
+DIST hydrus-452.tar.gz 38873698 BLAKE2B 3c9c5fc63533f9c94ff3425b8767bffacb20c435f7a904de1229ec3cb079d86009c971515461d55f947743c705b12eee798160cbae04f0c3af283666a82ac482 SHA512 5c0280ae80b9af32629f6a2bcab3466abd01eea502034ac2354e3efabfd7bbe5ae5582950a19d9f28019b993f847000aa194a0b810f4d32b143b24e589de9f66
diff --git a/media-gfx/hydrus/hydrus-452.ebuild b/media-gfx/hydrus/hydrus-452.ebuild
new file mode 100644
index 000000000000..d52bbf98e3b2
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-452.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 desktop optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+else
+ SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+# RDEPEND is sorted as such:
+# - No specific requirements
+# - Specific version or slot
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudscraper[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyside2[widgets,gui,${PYTHON_USEDEP}]
+ dev-python/python-mpv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ media-video/mpv[libmpv,${PYTHON_USEDEP}]
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI, not actually needed
+ rm -r static/build_files || die
+ # Duplicate license file, not needed
+ rm license.txt || die
+ # Python requirements files, not needed
+ rm requirements_*.txt || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
+ local HTML_DOCS=("${S}"/help/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
+
+ # These files are copied into doc
+ rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html/help" /opt/hydrus/help
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" || die)
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" || die)
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "automatic port forwarding support" "net-libs/miniupnpc"
+ optfeature "bandwidth charts support" "dev-python/pyside2[charts]"
+ optfeature "memory compression in the client" "dev-python/lz4"
+ optfeature "SOCKS proxy support" "dev-python/requests[socks5]" "dev-python/PySocks"
+}