summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-21 12:12:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-21 12:20:37 +0200
commitb6355d89b9bd7b657c3ad5680f899b6de75de1a7 (patch)
treef4e0403c0bb18db769eb55e73b1b78a6e1f5526d /media-gfx
parentmedia-sound/pnmixer: remove unused patch(es) (diff)
downloadgentoo-b6355d89b9bd7b657c3ad5680f899b6de75de1a7.tar.gz
gentoo-b6355d89b9bd7b657c3ad5680f899b6de75de1a7.tar.bz2
gentoo-b6355d89b9bd7b657c3ad5680f899b6de75de1a7.zip
media-gfx/exiv2: Tarball respun for CVE-2018-10999, CVE-2018-11531
Custom packed tarball based on upstream 0.26 branch as of 2018-08-11, with additional fixes from git master. Bug: https://bugs.gentoo.org/658236 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.26_p20180811-r1.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index bcec16778f66..8046b6981938 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1,2 +1,3 @@
DIST exiv2-0.26_p20180319.tar.gz 28383543 BLAKE2B 753a2ebdb2033490c0f66cb1fb2574f02125f17813f6cbaf5eca66e053af9a2cdbc1266f0a033f0706ec22b31acd6e87271e426a335a58ee947757b52d283489 SHA512 852ce2cffcc0a2d902a939933127fdf5fa0b50020e1faf3ab0a375b129b9f61c7b97b76d4f39e376e7288d7cc045867bd1a96ae15dd0b7c0bcd1ba15259628e1
DIST exiv2-0.26_p20180811.tar.xz 1746120 BLAKE2B 55d8719fd3726f2ead772b9b330dd9d452a6ddfd06df14d4d51a4139792de054bd891b7006f9813d5fa75cfd0a9dea1d0d254d8c978ef20cb9a14a9d294ab2cf SHA512 5f48b8e6cc22520059da388d184797090582df688bc04a32dd9ae6b80bacea4a2cbc81709c7274ba7ff1d8c5c318dd6428f027bdc63f590cedc83025cf0e5d51
+DIST exiv2-0.26_p20180811a.tar.xz 1722328 BLAKE2B 4b411dc24ed889fe978ad07bc3b3fafbf8db42eff9df9a221a02b715457c93eb8989397681bcaad4c12e0432dfcd782fbe10d1351d27da99debe422a7e142f3e SHA512 e5abab775c5bb7251af43912ba52b9ac90066369e3670104225337648470ba8c52e74c4b4e13a5609698e7d113eab4d277e8107db8b70496de6eaac22ec9ff63
diff --git a/media-gfx/exiv2/exiv2-0.26_p20180811-r1.ebuild b/media-gfx/exiv2/exiv2-0.26_p20180811-r1.ebuild
new file mode 100644
index 000000000000..21fda48c2b19
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.26_p20180811-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}a.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/26"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="doc examples nls png webready xmp"
+
+RDEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ webready? (
+ net-libs/libssh[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README doc/ChangeLog doc/cmd.txt )
+
+PATCHES=(
+ # TODO: Take to upstream
+ "${FILESDIR}"/${PN}-0.26-fix-docs.patch
+ "${FILESDIR}"/${PN}-0.26-tools-optional.patch
+)
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} != *9999 ]] ; then
+ if [[ -d po ]] ; then
+ pushd po > /dev/null || die
+ local lang
+ for lang in *.po; do
+ if [[ -e ${lang} ]] \
+ && ! has ${lang/.po/} ${LINGUAS-${lang/.po/}} ; then
+ case ${lang} in
+ CMakeLists.txt | \
+ ${PN}.pot) ;;
+ *) rm -r ${lang} || die ;;
+ esac
+ fi
+ done
+ popd > /dev/null || die
+ else
+ die "Failed to prepare LINGUAS - po directory moved?"
+ fi
+ fi
+
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ if use doc; then
+ einfo "Updating doxygen config"
+ doxygen &>/dev/null -u config/Doxyfile || die
+ fi
+
+ edos2unix samples/exiv2json.cpp # workaround for CVE-2017-18005 patch
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_ENABLE_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BUILD_PO=$(usex nls)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_SSH=$(usex webready)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_LIBXMP=NO
+ $(multilib_is_native_abi || echo -DEXIV2_ENABLE_TOOLS=NO)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && emake -j1 doc
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+ use doc && HTML_DOCS=( "${S}"/doc/html/. )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}