summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-14 15:05:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-14 16:52:26 +0200
commitca4eb0acc50c0bf41f1c5526b7b515df34e41258 (patch)
tree047d2901e4cf3d8bdd3f145b3f423da1ec6cd454 /media-gfx
parentmedia-gfx/graphviz: Add missing media-libs/libpng slot op, einstalldocs (diff)
downloadgentoo-ca4eb0acc50c0bf41f1c5526b7b515df34e41258.tar.gz
gentoo-ca4eb0acc50c0bf41f1c5526b7b515df34e41258.tar.bz2
gentoo-ca4eb0acc50c0bf41f1c5526b7b515df34e41258.zip
media-gfx/graphviz: Inline myconf comments
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphviz/graphviz-2.42.1.ebuild35
1 files changed, 12 insertions, 23 deletions
diff --git a/media-gfx/graphviz/graphviz-2.42.1.ebuild b/media-gfx/graphviz/graphviz-2.42.1.ebuild
index 6a0e38d17e8a..a26f2b5c6df4 100644
--- a/media-gfx/graphviz/graphviz-2.42.1.ebuild
+++ b/media-gfx/graphviz/graphviz-2.42.1.ebuild
@@ -187,14 +187,6 @@ src_prepare() {
src_configure() {
local myconf=(
--enable-ltdl
- --disable-silent-rules
- $(use_enable static-libs static)
- )
-
- # libtool file collision, bug 276609
- myconf+=( --without-included-ltdl --disable-ltdl-install )
-
- myconf+=(
$(use_with cairo pangocairo)
$(use_with devil)
$(use_enable gdk-pixbuf)
@@ -204,6 +196,7 @@ src_configure() {
$(use_with lasi)
$(use_with pdf poppler)
$(use_with postscript ghostscript)
+ $(use_enable static-libs static)
$(use_with svg rsvg)
$(use_with X x)
$(use_with X xaw)
@@ -215,35 +208,31 @@ src_configure() {
--with-libgd
--with-sfdp
--without-ming
- )
-
- # new/experimental features, to be tested, disable for now
- myconf+=(
+ # new/experimental features, to be tested, disable for now
--with-cgraph
--without-glitz
--without-ipsepcola
--without-smyrna
--without-visio
- )
-
- # Bindings:
- myconf+=(
+ # Bindings:
$(use_enable guile)
- --disable-io
$(use_enable java)
+ $(use_enable perl)
+ $(use_enable python python2)
+ $(use_enable python python3)
+ $(use_enable ruby)
+ $(use_enable tcl)
+ --disable-io
--disable-lua
--disable-ocaml
- $(use_enable perl)
--disable-php
--disable-python
- $(use_enable python python2)
- $(use_enable python python3)
--disable-r
- $(use_enable ruby)
--disable-sharp
- $(use_enable tcl)
+ # libtool file collision, bug #276609
+ --without-included-ltdl
+ --disable-ltdl-install
)
-
econf "${myconf[@]}"
}